[Samba] Name lookup failure - NetBIOS lookup administratively prohibited

Angus Monro angus.monro at s4b.com.au
Thu Jan 27 06:49:34 GMT 2005

I’m a Samba newbie trying to set-up a test system with a Redhat samba server
and a WinXP laptop.  As much as I’ve worked throught the troubleshooting
guide and setup info in the Samba HOWTO, I’m not winning.  I’ll describe my
setup first, then my symptoms along with what I’ve found when I’ve tried to
dig deeper.



The Redhat and the WinXP boxes are communicating via a wireless router, with
the Redhat having a physical connection to the router and the WinXP having a
wireless connection via WEP.  Firewalls are disabled. DHCP is the order of
the day.

The Redhat’s smb.conf is


                        workgroup = s4b                        

                        netbios name = s4bServer

                        security = SHARE

                        hosts allow = 192.168.0.  127.


                        path = /shareds4b

                        comment = testfiles

                        read only = Yes

                        guest ok = Yes

                        guest only = Yes

/shareds4b exists and has 0777 permissions.

The Redhat’s IP is


The WinXP is configured with workgroup s4b.

Its IP is  Its name is ‘S4B-2-TOSHIBA’


The router has IP



The units can ‘see’ each other when I use IP addresses, but names are not


On the Redhat box


I eventually got smbclient –L s4bServer to work by explicitly putting
s4bserver in my /etc/hosts, so it works now.

BUT it doesn’t list the WinXP box under the SERVER heading (although I can
ping the WinXP box by IP address)

Doing nmblookup –B S4B-2-TOSHIBA ‘*’  fails to print the laptop’s ip

Doing nmblookup –B  ‘*’  fails, saying “name_query failed to
find name *”.


On the WinXP box

s4bServer isn’t appearing in My Network Places.  If I try to add it
explicitly via Add a Network Place, s4bServer is indeed appearing under the
s4b workgroup (that’s one good thing!), but no share folders are being
listed under it.

Doing net use e: \\s4bServer\share1  complains “The network name cannot be


If I run ethereal on the Redhat box and do a ping s4bServer on the WinXP
box, ethereal shows that the Redhat is indeed picking-up the NetBIOS NBNS
broadcast message, but is responding with ICMP Type 3 Code 10 (“Host
administratively prohibited”).


OK, I can see that there’s some sort of name lookup problem going on here;
but I’m surprised by the ICMP response, since I thought that nmbd’s purpose
in life was to respond correctly to these messages.  What have I missed? 


Angus Monro




s4bPty Ltd

Method House for R.A.A.D (Risk Avoidance Architectures Design) 

Solution Architects, System and Software Designers, Business Specialist 


(m) +61 421 454 671

(p) +61 3 9909 7358

(f) +61 3 9887 5056 

(e) HYPERLINK "mailto:angus.monro at s4b.com.au%20"angus.monro at s4b.com.au 


This communication is intended for the named recipients only. It is
confidential and may contain information which is privileged or personal. If
you are not an intended recipient you must not disclose or use this
communication for any purpose. If you have received this communication in
error, please call us collect on Australia +61 39887 5056 and then destroy
the communication or delete it from your computer system.


Outgoing mail is certified Virus Free.
Checked by AVG anti-virus system (http://www.grisoft.com).
Version: 6.0.846 / Virus Database: 575 - Release Date: 26/01/2005

More information about the samba mailing list