[Samba] Lingering WinXP SP2 issues

Ryan Novosielski novosirj at umdnj.edu
Fri Jan 14 22:12:20 GMT 2005

I have this problem. Well, I don't have it now. Here's when I started to 
have it. I have queues named things like \\njmsa-lm\djnlab. I decided, 
when I noticed the names are stored in .tdb's, not smb.conf, that I would 
rename them to more civilized names from the Windows side. I called the 
afforementioned printer:

\\njmsa-lm\Lab Poster Printer (djnlab)

...this worked... sometimes. Sometimes I'd see the error above. I made it 
go away by naming things back the way they were, but I'd really like to do 
what I described. The other thing that seemed to cause it sometimes (or 
cause other confusion) was having a djnlab and djnlab1 (djnlab1 was mapped 
from a staff machine only and was rather unrestricted, djnlab was mapped 
from lab machines and had a time-of-day restriction). Occaisionally, it 
appeared as if a change to one would affect the wrong printer.

Another related note: why is it that installing a new printer driver 
renames the printer? (ie. set up share, djnlab. Install printer Driver. 
Printer gets named hp designjet 42 ps3 without my permission). Is this 
expected behavior?

---- _  _ _  _ ___  _  _  _
|Y#| |  | |\/| |  \ |\ |  |  | Ryan Novosielski - User Support Spec. III
|$&| |__| |  | |__/ | \| _|  | novosirj at umdnj.edu - 973/972.0922 (2-0922)
\__/ Univ. of Med. and Dent. | IST/ACS - NJMS Medical Science Bldg - C630

On Thu, 13 Jan 2005, David Schlenk wrote:

> On Jan 13, 2005, at 12:11 PM, Paul Gienger wrote:
>>> from connecting to this print queue. Please contact your system 
>>> administrator." on a select few queues.  This occurs only on WXP SP2 
>>> machines
>> You didn't have this issue before SP2?  AFAIK, you should see this all the 
>> time (SP2 or not, even w/2000) when a non-admin user connects, provided the 
>> printer hasn't been installed already as by someone with admin.
> Nope. Worked fine, prior. I will play around with that and see if I can get a 
> pattern though.  It does only affect certain drivers, so maybe it wasn't 
> supposed to be working before and now correctly isn't working.
> ---
> On Jan 13, 2005, at 12:18 PM, Misty Stanley-Jones wrote:
>> On Thursday 13 January 2005 13:11, Paul Gienger wrote:
>>>> Has anyone else had this behavior? Any fixes (deleting tdb files
>>>> perhaps)?
>>> It's a client side issue, no server changes would fix it aside from
>>> making the user a member of Domain Admins, thereby giving local admin.
>>> That's most likely not what you REALLY want to do though.
>> It would be solved by using [PRINT$] share and storing all your printer
>> drivers on the server.  A normal user will be able to connect to a network
>> printer but won't be able to install any drivers.  The only users of mine 
>> who
>> have to be administrator are the ones who need to use a printer which will
>> not store its drivers on the server.
> I do this already. Used to work great. :)
> --
> David Schlenk
> Operating Systems Analyst
> Bethel University
> Saint Paul, Minnesota
> david-schlenk at bethel.edu
> -- 
> To unsubscribe from this list go to the following URL and read the
> instructions:  https://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list