[Samba] session setup failed: Call returned zero bytes (EOF)

Clay clayway at excite.com
Mon Feb 28 04:04:48 GMT 2005

Hello All,

I have been running samba-3.0.7 with acl/ldap support and decided to 
upgrade to samba-3.0.11......after the install..

I start samba and smbd/nmbd start as expected....so I check to see if I 
can connect with smbclient -L localhost -U username

After the password entry...i get the following message.....

session setup failed: Call returned zero bytes (EOF)
NetBIOS over TCP disabled -- no workgroup available

At first I thought it was me....so I decided to try samba-3.0.9.....did 
my configure and started samba...smbclient connected as expected...

So I tried samba-3.0.10..everything worked as expected.....

I went back to samba3.0.11 and decided to read the WhatsNew file...the 
only thing I noticed was about ldap machine and user suffix....so I 
rem'ed my out of smb.conf......same session setup failed....

I copied the samba-3.0.11/samba.schema into my openldap/schema 
directory....no luck there either....

I configured with the same options on all versions samba-3.0.7,9,10,11

./configure --prefix=/usr/local/$VERSION \
--enable-cups \
--with-smbwrapper \
--with-smbmount \
--with-automount \
--with-acl-support \
--with-ldap \

What am I missing....

I checked the var/log.smbd and nothing jumps out at me as being wrong or 

Thanks for any help you can give me....


More information about the samba mailing list