[Samba] Samba Problem

Doug VanLeuven roamdad at sonic.net
Sat Feb 26 02:38:40 GMT 2005

Hi Gerry,

gerard.lynch at americas.bnpparibas.com wrote:

>this is really a last resort as I'm literally pulling my hair
>out over AIX and Samba and cannot find any threads on this particular
>Basically we have  3 systems running  AIX 5.1 and Samba  2.2.7
>We upgraded one system to Aix 5.2 and everything works no problem.
>Upgraded the next  two and both will not join the domain using
>the   smbpasswd -j  domain-name -r  ny0000000 -U  myaccount.
>After the password is entered they just hang even although I can query
>the domain using  smbclient -L  ny0000000 -U myaccount.
>Tried re-installing etc and to no avail so now we're out of ideas and
>need to get 5.2 working with Samba. Note also tried  newer versions of
>Samba too.
>Any suggestions you may have would be great
I originally migrated to AIX 5.2 by recompiling samba 2.2.8a and just 
running it without changing any of the samba config or data files.  
There was no need to rejoin.

I don't know if it's too late for that, but potentially you could 
restore a backup of the samba install/private directory from before you 
tried to join and it should just work unless the machine password has 
already been changed.

Other than that, once or twice my AIX samba got out of sync with the 
domain controller.  I found I had to delete the old account on the PDC 
before attempting to create a new one from the command line.  But don't 
do that until the backup fails to work.

myaccount would need to be a domain admin.

Regards, Doug

More information about the samba mailing list