[Samba] Symlinks followed literally in Debian 3.0, not in Red Hat 7.3

Stephen D. Benning benn0224 at umn.edu
Thu Feb 24 14:54:52 GMT 2005

After receiving requests to post answers to this query,
I figured I'd resubscribe to let people know that there is,
in fact, a way around this.  When I upgraded johnboy to Linux
kernel version 2.6.10, all the formerly problematic symlinks
worked.  Apparently, the 2.6.10 kernel fixed some issues in
the smbfs code relating to symlinks (thanks to Ted McManus for
pointing this out to me).  So if you're running Linux clients,
my advice is to upgrade them to kernel 2.6.10.

| Hi all,
| I've encountered a problem in using Samba 3.0.4.  I've got a Red Hat
| box (johnboy) running as a domain controller, and we've got symlinks
| a bunch of NFS mounts on a different machine (pawalton) to give people
| the necessary file access using only one SMB mount.  For example, the
| SMB share is under /smbfiles in the root directory of the Samba
| Within /smbfiles, there are three symlinks.
| /smbfiles/share1 points to /mounts/pawalton/hda/root/files
| /smbfiles/share2 points to /mounts/pawalton/hdb/user_files
| /smbfiles/share3 points to /mounts/pawalton/hdb/admin_files
| I use an ssh tunnel to forward the smb port on johnboy to my local
| machine (doublemint), and the port forwards quite nicely.  I can get
| access to my files using smbclient.  However, when I try to mount
| /smbfiles from johnboy onto the mountpoint I've created on doublemint
| (/shares/johnboy) with smbmount, it creates three broken symlinks that
| act as if they're trying to point to the locations of the files on
| johnboy!
| share1 -> /mounts/pawalton/hda/root/files
| share2 -> /mounts/pawalton/hdb/user_files
| share3 -> /mounts/pawalton/hdb/admin_files
| I've Googled around, read the documentation, and futzed with this for
| about three days straight now, and I can't get smbmount to just mount
| the directories (as my other Red Hat 7.3 box does, with no problems).
| I've also tried reinstalling Samba 3.0.4 on johnboy, to no avail.
| The "follow symlinks" option in smb.conf is set to yes.  Is this a
| peculiarity to Debian, or is this a bug that's more generally known?
| I'd like to be able to mount these directories, rather than their
| symlinks.
| Stephen
Stephen D. Benning
Department of Psychology
University of Minnesota
Office: N631 Elliott Hall
75 East River Road
Minneapolis, MN  55455
E-mail: benn0224 at umn.edu

More information about the samba mailing list