[Samba] Bringing a laptop to a Samba Network

Steve Cohen scohen at javactivity.org
Thu Feb 24 00:28:39 GMT 2005

Craig White wrote:

 > On Tue, 2005-02-22 at 23:41 -0600, Steve Cohen wrote:
 >> Steve Cohen wrote:
 >>> I have a little home network, with a wireless router.  The main box 
on the ntwk runs RedHat 9.0 and Samba 2.2.7a.
 >>> I have a Win2K laptop provided to me by my employer with all the 
typical corporate security constraints.
 >>> I can take the laptop home and access the internet from it through 
the laptops secondary wireless router card and my wireless router.  What 
I'd like to be able to do beyond that is print documents from the laptop 
to my home printer.  It won't work.  The laptop can see the printer, but 
Samba is not letting it access the printer.  The laptop is within the 
corporate domain of my employer.  You can't sign on otherwise.  It's not 
in Samba's workgroup, which seems to be assumed by many of the docs I've 
read.  (In a catastrophically comic attempt to do this, I tried changing 
the laptop's Network identification to use the Samba workgroup.  Not 
only didn't this work, but I couldn't change it back, and once I was 
logged off, couldn't log back on.  I had to get the work IT guys to 
reconfigure it back to the corporate domain.)
 >>> So, is there a way in Samba to give access to a computer outside 
its workgroup?  What might that be?  A quick perusal of the docs that 
come with SWAT didn't suggest anything promising.
 >> One more detail of my setup: security = SHARE
 > ----
 > I would expect that you could access 'My Network Places' -> View Entire
 > Network -> Microsoft Windows Networking -> NAME_OF_HOME_WORKGROUP ->
 > Samba_Server and see the printer share and then double click to install
 > and set up.

I see only the corporate network when I do this.  It is empty, unless I 
enter the corporate VPN, at which point I see all the computers in the 
corporate network that I would see if at work but not my local workgroup.

 > You probably will need to install printer driver for your
 > home printer. Likely you aren't going to have sufficient privileges to
 > add a printer and install a printer driver (you probably wouldn't if I
 > was admin of your network anyway)

I have sufficient privileges for installing the driver.  In fact, I have 
gotten as far as installing this as a printer on the laptop.

 > Privileges though wouldn't prevent you from accessing your home
 > workgroup and seeing file & printer shares. It's likely that WINS server
 > stuff is set for work environment and thus, you may have to simply
 > connect to samba server by ip address...

Yes.  I type in the ip address and I see the printer and all the other 
Samba shares.  Doubleclicking on the printer I get
"Access Denied, Unable to Connect" in the window title bar for the 
printer.  Windows will let me "print" to it, but nothing happens.

 > Try some command line stuff on laptop like...
 > or if unable to resolve the name...
 > and of course you can try stuff like...
 > but of course, you would want the driver to be installed.

This "succeeds" but again, no printing happens.

 > Craig

What I didn't say before was that at one time this worked.  I was able 
to print through this same connection.   Two events intervened:
1.  There was a glitch in the wireless router and I had to reset it to 
factory settings and reconfigure, which I believe I did successfully.
2.  I updated my samba rpm from 2.2.7a-7.9.0 to 2.2.7a-8.9.0

One or both of these things may have messed with the config.

 From all the above, it seems to me that Windows is letting me out to 
see the printer, even connect a driver to it.  But something in Samba is 
preventing me from accessing, and after looking all up and down the 
smb.conf, I don't see it.


$ cat smb.conf
# Samba config file created using SWAT
# from RAINIER (
# Date: 2005/02/16 22:34:37

# Global parameters
         workgroup = {NAME OF MY WORKGROUP}
         server string = samba server
         security = SHARE
         encrypt passwords = Yes
         obey pam restrictions = Yes
         pam password change = Yes
         passwd program = /usr/bin/passwd %u
         passwd chat = *New*password* %n\n *Retype*new*password* %n\n 
         unix password sync = Yes
         log file = /var/log/samba/%m.log
         socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
         printcap name = cups
         preferred master = No
         domain master = No
         dns proxy = No
         wins server =
         guest ok = Yes
         hosts allow =
         printing = cups

         comment = Home Directories
         valid users = %S
         writeable = yes
         create mask = 0664
         directory mask = 0775
         browseable = No

         path = /tmp
         guest account = ftp
         writeable = yes

         comment = All Printers
         path = /var/spool/samba
         printable = Yes
         use client driver = Yes
         browseable = No

         path = /var/spool/samba
         writeable = yes
         printable = Yes
         printer name = EpsonC82

         path = /var/spool/samba
         writeable = yes
         printable = Yes
         printer name = raw_q

More information about the samba mailing list