[Samba] Samba partialy responding on 1 ethernetcard

Pascal Nobus pascal at nobus.be
Wed Dec 21 11:16:42 GMT 2005

Since a couple of days I have a very strang thing...

Machine-A : eth0
  (linux)    eth1 x.x.5.37

Machine-B : eth0
  (win2k)    eth1 x.x.5.10
	    eth3 not configured

Machine-C : eth0

Machine-B was mounted on Machine-A on /mnt/d (through
Machine-C was mounted on Machine-B on /mnt/c (through

After a power-failure on our switch, /mnt/d can be mounted but I can't 
read anything: ls /mnt/d freezes, and in smbmount.log I get:
[2005/12/21 11:03:06, 0] tdb/tdbutil.c:tdb_log(725)
   tdb(/var/cache/samba/gencache.tdb): tdb_lock failed on list 10 
ltype=1 (Bad file descriptor)

However some things are working: df -h
//    38G  8.5G   29G  23% /mnt/d

If I mount Machine-B through the other network-card it works just fine.
--> this assumes the problem is within the 192.168-network or cards.

Mounted Machine-C on Machine-B: no problem
Mounted Machine-C on Machine-A: no problem
--> the card of machine A+B+C must be fine

Then fixed a cross-cable between Machine-A en B (192.168-cards), and it 
also works just fine:
--> assuming the problem is within the switch or cabling.
But this is very strange, cause the mount of Machine-C is also through 
that switch and cable.

Removed all the cables, tried another switch: still no response!

After this I assigned eth3 on Machine-B with the address of eth0, and 
now it works fine.

Can somebody give me a clou what's going on, or where to look?

Best regards,

More information about the samba mailing list