[Samba] problem with unix extensions on Adaptec SNAP Server (Redhat 8)

ed at whsd.k12.pa.us ed at whsd.k12.pa.us
Wed Dec 7 21:49:30 GMT 2005

I've recently purchased an Adaptec SNAP server to serve as a central file 
server for a 2500 machine, 7000 user network.  My goal is for this server 
to serve as a backend file store to a number of other servers that the 
client machines will communicate with.  In particular, I would like to have 
my current file server (which runs samba 3.0.10 in kernel 2.6.10-gentoo-r6) 
mount a share on the snap server and reshare it to the clients with:

mount -t cifs //gaea/data /mnt/smbfs -o 

where gaea is the name of the snap server and weyland is the name of the 
client I am testing this with.  If I run this command against my current 
samba server everything works as expected (i.e. I can login to 'weyland' 
with a user that doesn't exist on the server and create files whose owner 
is set correctly).  If I run this command against the snap server I am able 
to create files but the owner is set to the user specified on the mount 

I tried to escalate this problem through Adaptec tech support to no avail. 
  I theorized that adaptec may have patched samba in a strange way to 
somehow disable 'unix extensions'.  I discovered that the Adaptec snap 
server is just a stripped down Redhat 8 box (through /lib/libc.so.6), so I 
compiled samba 3.0.20b on another Redhat 8 box and moved the binary (and 
some shared objects) to the snap server.  I functions in the same way (I 
can create, move, etc. files but their owner is set incorrectly).

My understanding is that any version of samba >= 3.0 supports the unix 
extensions from the server standpoint regardless of what kernel, etc. the 
server is using, but the experiences I've detailed above seem to prove this 
wrong.  I'd really like to get this working so I'd appreciate any insights.


Ed Stoner
Network Administrator
Woodland Hills School District
2430 Greensburg Pike, Pittsburgh PA

More information about the samba mailing list