[Samba] Re: Samba Question

John H Terpstra jht at Samba.Org
Wed Apr 20 16:44:31 GMT 2005

On Wednesday 20 April 2005 10:39, David Michaels wrote:
> Worth noting:  The 3.0.x recommendation regarding nscd is that you /do
> not run it at all/.  Though I think that might only apply when you're
> using winbindd, you might want to take a look at your nscd process to
> see if it's notably busy.  It was on our server, taking up half of one
> of the CPUs.  Very bad.  So I turned nscd off.

The recommendation not to run nscd applies only when winbind is running.

- John T.

> --Dragon
> Gerry Maddock wrote:
> >Got it working. I had to restart nscd service. Nscd was not reflecting the
> >group entries.
> >
> >>Ok, it seems to be an LDAP problem. for some reason linux isnt reading
> >> the ldap groups, even though /etc/nsswitch.conf states groups = files
> >> ldap Here is my problem:
> >>
> >>I ran smbldap-groupadd TEST to create the group test. I then ran:
> >>smbldap-groupmod -m gerrym,briang TEST to add gerrym (me) and briang to
> >>that group. I next created a test linux directory called TESTDIR to check
> >>permisions. I changed the ownership to briang.TEST TESTDR (chown
> >>briang.TEST ./TESTDIR). I then changed directory permisions to 770 (user
> >>and group have read,write,and execute). I then logged in as my self
> >>(gerrym) and tried to access that directory and I am unable to. The
> >>directory permisions should allow me in w/full control as I am in the
> >>group TEST. I run getent group|grep TEST and verify I am a member of that
> >>group and I am. I then checked /etc/nsswitch.conf and it shows:
> >>group:      files ldap
> >>
> >>Just wondering why it will not let me in that directory if permisions are
> >>right? I used IDEALX's smb-ldap script 1.2. Any help or suggestions would
> >>be
> >>appreciated. THANKS!
> >>
> >>>I have a share access question for you. I have been running Samba 2.2.7
> >>>as
> >>>a PDC on my RH7.2 box for several years now. I just setup a new PDC
> >>>running Samba 3.0.10 on a FC3 box. I used to control read-write acces to
> >>>shares via samba like:
> >>>[TRData]
> >>>        path = /tr/TRData
> >>>        valid users = administrator, at IT, at fl, at tx, at eu, at ca, at ny, at wa, at uk
> >>>        write list = administrator, at IT, at FLTR
> >>>        force group = FLTR
> >>>        read only = no
> >>>        create mask = 0777
> >>>        directory mask = 0777
> >>>
> >>>That would work fine when I was running Samba 2.2.7, but now it doesnt
> >>>work with Samba 3.0.10. What can I enter to my new smb.conf (3.0.10) to
> >>>get the shares to behave like they did when I ran 2.2.7?
> >>>
> >>>Thanks in advance!!!

John H Terpstra
Samba-Team Member
Phone: +1 (650) 580-8668

The Official Samba-3 HOWTO & Reference Guide, ISBN: 0131453556
Samba-3 by Example, ISBN: 0131472216
Hardening Linux, ISBN: 0072254971
Other books in production.

More information about the samba mailing list