[Samba] smbclient to sent message to windows users fails

Marcel J.E. Mol marcel at mesa.nl
Tue Apr 19 07:42:40 GMT 2005


Up till a few months ago I had no problems sending popup messages to
windows-xp pcs like this:

 echo "New fax arrived $pages pages" | /usr/bin/smbclient -U FAX -M jo >>/tmp/smbclient.log

Lately however this does not work anymore.  The log file contains nothing
at all. This was still with samba 2.2.3 on an readhat 7.2 server.

I'm not really aware of chagend to the windows clients (windows-xp
profesional), but then again some auto update might have caused this.

I tried upgrading to the latest samba rpm that worked on redhat 7.2 and
am now running samba 2.2.7. Still the messages won't get through, but there
are some messages in the log.
In some cases:

   added interface ip= bcast= nmask=
   Got a positive name query response from ( )
   Connected. Type your message, ending it with a Control-D
   sent 51 bytes

And in other cases:

   added interface ip= bcast= nmask=
   Cannot resolve name jo#0x3

(I don't understand where this #0x3 comes from...)

But no messages appear at the client.

I looked in howtos and searched the web but could not find anything usefull.

Does anyone know how to fix this...


     ======--------         Marcel J.E. Mol                MESA Consulting B.V.
    =======---------        ph. +31-(0)6-54724868          P.O. Box 112
    =======---------        marcel at mesa.nl                 2630 AC  Nootdorp
__==== www.mesa.nl ---____U_n_i_x______I_n_t_e_r_n_e_t____ The Netherlands ____
 They couldn't think of a number,           Linux user 1148  --  counter.li.org
    so they gave me a name!  -- Rupert Hine  --  www.ruperthine.com

More information about the samba mailing list