[Samba] POSSIBLE RESOLUTION: Extremely slow during browsing some directories (MS KB Articles)

Linwei Cheng hcheng at sjgeophysics.com
Wed Apr 13 19:18:50 GMT 2005


I thought over my previous problem again, and feel samba was not guilty for 
my issue. Although I am still not quite sure, it seems that the 
mal-configured EXT3/LVM/RAID caused the problem. I remember that after I 
first installed Samba and made share on a ext3 file system which is a LVM 
volume which is on software RAID1 disks, everything works fine. The evil 
began after I "did something" on extending the LVM size and do "resize2fs" 
to extend the filesystem as well. The possibility is I screwed up with the 
LVM device and RAID device and Disk device and filesystem at the very time. 
I ALSO experienced system crush several times after I did that. So, when I 
went over all the devices and did the LVM extending again very carefully, 
the issue disappeared. The machine is running for about 3 weeks without the 
same problem raise again.

( I do simple "share" security now so it should be no problem on 
authentication delay ).

My system info is now:
kernel: 2.6.10-1.770_FC3
samba: 3.0.13 ( updated from 3.0.12pre )
LVM2: 2.00.25-1.01
Mdadm: 1.6.0-2

Hope this could do some help for others suffered similar problem as mine.

Lin wei

----- Original Message ----- 
From: "Jonathan Johnson" <jon at sutinen.com>
To: <samba at lists.samba.org>
Sent: Friday, April 01, 2005 1:11 PM
Subject: [Samba] POSSIBLE RESOLUTION: Extremely slow during browsing some 
directories (MS KB Articles)

>A colleague ran across this Microsoft (lack of) Knowledge Base article:
> "Long delay in the display of file names from the "Open" dialog box in 
> Office XP"
> http://support.microsoft.com/kb/818792
> which lists a hotfix available from Microsoft. Also, on some Microsoft 
> discussion lists, there's been some experience that the presence of an 
> invalid/disconnected mapped drive can impact the issue, or the presence of 
> a large number of files/folders in the folder being browsed..
> In addition, there's another article:
> "The File Open dialog box does not automatically select the first 
> available document in an Office 2003 program"
> http://support.microsoft.com/kb/832889
> which contains this tidbit of wisdom (and references article 818792):
> "If the AutoSelect feature is enabled in the *Open* dialog box, and you 
> view a folder on a network share that contains many files and folders, you 
> may experience a delay of two to five minutes before the *Open* dialog box 
> is populated and the first available Office 2003 document is selected."
> In reading these two articles, I get the sense that in Office XP (Office 
> 2002) "it's a feature not a bug" and that in Office 2003, "it was a buggy 
> feature so we disabled it by default." Even though it's supposed to be 
> disabled in 2003, you might want to double-check the registry hack 
> mentioned in 818792, maybe setting DisableAutoSelect to 1 just to be sure.
> --Jonathan Johnson
> Sutinen Consulting, Inc.
> jon at sutinen.com
> Jonathan Johnson wrote:
>> David Rankin wrote:
>> >>
>> I am seeing the exact same problem and I can confirm that a reboot of Win 
>> XP helps the problem temporarily. (this is my laptop so it is restarted 
>> regularly) It seems something is getting cached or stuck somewhere after 
>> XP is up and running for a while that is causing the 30 second delay 
>> descending down the directory tree when using the "file-open" dialog from 
>> MS office applications.
>> <<
>> David,
>> For what it's worth, I've experienced very similar behavior with a Novell 
>> server in the back end. Unfortunately, I don't know enough about Novell, 
>> and there isn't a Samba server on this particular network that I can use 
>> for troubleshooting. I mainly wanted to let you know that it's not just a 
>> Samba problem, but perhaps some "optimization" that Microsoft has used to 
>> make sure that their server OS works better. We can always suspect that, 
>> can't we?
>> In my situation, browsing works fine with explorer but not in the file 
>> open dialog in MS Office apps. Just like you experienced.
>> In regards to Linwei Cheng's original problem, I have to ask, is there a 
>> machine account in the /etc/passwd file? For one of my customers who has 
>> a Samba box that authenticates against a true Windows Active Directory 
>> server, I found that I needed to add local machine accounts to the Linux 
>> user database (/etc/passwd) in order to get reasonable performance. The 
>> Samba logs were full of messages whining about user MACHINE$ not 
>> existing. Now, I might have solved this by adding winbind to the hosts 
>> entry in /etc/nsswitch.conf, but I didn't think of that. It works now, so 
>> why fix it?
>> --Jonathan Johnson
>> Sutinen Consulting, Inc.
>> www.sutinen.com

More information about the samba mailing list