[Samba] Can really anyone help ?

CIKALA Fr é d é ric ROSI/SIPROD frederic.cikala at francetelecom.com
Wed Apr 6 13:18:52 GMT 2005

I know that it is the right way to use this ML but as nobody answered me, i repost this help ...
in fact, it is quite hurry, and i want to understand ...
Why do the mount -t smbfs just halfWork ?? can see some directories, but see no file ! :o ...
Hello everyone,
I'm having such a strange problem and i hope you'll understand the situation.
I want to access files that are shared by a Windows server, from a linux box, by using a login/pwd.
To be sure that these login/pwd has the good rights, i tested it.
>From a windows box (which is in the same active Directory domain of the file server -which is "AD") i tried to mount the remote HD whith the login/pwd, and everything is ok.
it works fine
But when i use the mount command (from my linux Fedora box #mount -t smbfs ...) i get somme errors but in my /mnt/partage, i can see directories. I also can get trought these, but i cannot see any file .... quite strange isn't it. look :
[root at pcp423960pcs html]# mount -t smbfs -o username="AD\user" //  /mnt/partage
27930: session request to failed (Called name not present)
27930: session request to 10 failed (Called name not present)
[root at pcp423960pcs html]# ls /mnt/partage/
01/      5H/      5Q/      6S/      9R/      D0/      J1/      Login/
02/      5M/      6H/      6X/      AA/      H3/      J2/      V0/
4D/      5P/      6M/      8A/      ADMINNT/ H5/      J4/
[root at pcp423960pcs html]# ls /mnt/partage/6H/ACG/Directions/
[root at pcp423960pcs html]#

before the command, /mnt/partage is empty
I'm not at all an expert of Active Directory but maybe it is impossible to see the files of a filer if the source machine doesn't belong to the same ActiveDirectory Domain.
And the docs i found about kerberos or samba are about the users of a Samba SERVER, not about the client.
Maybe can someone help me, i sincerly hope because i already spent 3 days about this problems.
Moreover, i do not want to return to the old web/Php config (which was an NT4 +esayPhp :-/ ... but it worked ...)

More information about the samba mailing list