[Samba] Can't add new users

Yang Xiao yxiao2004 at gmail.com
Thu Sep 30 21:33:03 GMT 2004

On Thu, 30 Sep 2004 13:49:45 -0700, Majid Chavoshi <majidc at belkin.com> wrote:
> Hi all,
> I tried to add a new user to a Samba share, I did all the usual: made a Unix account on the Unix server for the user which was the same as the user's window's UID. Put her name as a valid user for that directory in server:/etc/opt/samba/smb.conf, and stopped and started server:/sbin/init.d/samba server; nothing worked.
> Interesting observations: 1- After performing the steps described above, I do a "server# /opt/samba/bin/testparm" and don't even see the new user's name for that particular Samba share. 2- Samba is working fine for all the previously defined users in smb.conf.
> Many thanks in advance and best regards.
> Majid Chavoshi
Does "id username" work? if that's the case, sounds like you have
multiple smb.conf files
do "testparm /path/to/smb.conf"
make sure your /etc/init.d/smb points to the correct smb.conf file.


More information about the samba mailing list