Scott George Scott.George at DigitalControls.com
Mon Sep 27 14:39:20 GMT 2004

I added the username in the smbclient command to my Solaris box as a
normal users, with the same password.  The smbclient command works now.
Now my questions is:  How do I tell Samba to go directly to the ADS
server(s) for authentication, instead of authenticating locally?  I
tried putting winbind in my /etc/nsswitch.conf in the passwd line, but I
got this when trying to set a passwd:
# passwd username
passwd: Unsupported nsswitch entry for "passwd:". Use "-r repository ".
Unexpected failure. Password file/table unchanged.
So I removed that entry and set the password successfully, and it
worked.  Smbclient then worked too.  I have 50 users that are going to
use this share, so this is not going to be the solution I need.  I will
RTFM again to see if it will get me beyond this, now that I know where
my problem is.

I use smbclient to attempt to connect to a share on my local server.
Here is what happens:
./smbclient //host/share -U username -W domain
session setup failed: NT_STATUS_LOGON_FAILURE
Here is my smb.conf file:
       workgroup = DOMAIN
       realm = DOMAIN.TLD
       server string = Solaris 9
       security = ADS
       auth methods = trustdomain, winbind, sam
       password server = server.domain.tld
       wins server =
       ldap ssl = no
       path = /store
       read only = No
I have it added to the ADS domain, I did this via the net command.  
I can mount remote shares via the smbclient command, and can view files
in those shares. 
I am using Solaris 9/Samba 3.0.7/OpenLDAP 2.2.17/Kerberos 5 1.3.5
Thank you in advance for any guidance.

Scott George
Customer Support Engineer
Digital Controls Corporation
Technology Services Group

More information about the samba mailing list