[Samba] samba not printing queue

Samuel R. Waters srw at cs.rit.edu
Tue Oct 19 17:49:26 GMT 2004

Hi folks-

I'm having a problem with Samba printing from Windows to Solaris printers,
running samba 2.2.8a.  At the moment, when windows jobs sent to samba,
samba is copying them to /var/spool/samba, but not starting printing.
This worked fine until yesterday, and nothing in Samba has been touched
(at least, not to my knowledge).  We use SystemV printing, which works on
the unix side-I can go to /var/spool/samba and run lp [file name] without
a problem.

I've tried changing the smb.conf to use BSD printing and tried several
different print command = ,  to no affect.  All the other features seem to
work (shares, PDC authentication), just not printing.  Is there an
process in addition to smbd and nmbd that needs to be running?  I've tried
everything the howto's and google have turned up, but I'm out of ideas-any
help would be appreciated.

here's the relevent smb.conf info:

        max print jobs = 1000
        printable = No
        postscript = No
        printing = sysv
        print command = lp -c -d%p %s; rm %s
        lpq command = lpstat -o%p
        lprm command = cancel %p-%j
        lppause command = lp -i %p-%j -H hold
        lpresume command = lp -i %p-%j -H resume
        queuepause command = disable %p
        queueresume command = enable %p
        printer name =
        use client driver = No
        default devmode = No
        printer driver =
        printer driver file = /opt/samba/lib/printers.def
        printer driver location =

        comment = All Printers
        path = /var/spool/samba
        guest ok = Yes
        printable = Yes
        browseable = No


Sam Waters

Samuel R. Waters					srw at cs.rit.edu
System Administrator
Department of Computer Science				(585)475-4934
Rochester Institute of Technology

Questions?  Start here: http://www.cs.rit.edu/~srw

More information about the samba mailing list