[Samba] Point'n'Print: adddriver / WERR_ACCESS_DENIED

Philip Maurer philip.maurer at novasoft.fi
Mon Oct 11 11:44:30 GMT 2004

I guess this directory listing should answer your questions:

total 577
drwxr-xr-x  2 root root     48 Oct  5 16:34 2
drwxr-xr-x  2 root root     48 Oct  5 16:34 3
-rwxr--r--  1 root root  65645 Oct  5 16:17 HP_LaserJet_4100_Series.ppd
-rwxr--r--  1 root root  14234 Oct  5 16:17 cups5.hlp
-rwxr--r--  1 root root 280268 Oct  5 16:17 cupsdrv5.dll
-rwxr--r--  1 root root 219540 Oct  5 16:17 cupsui5.dll

total 0

total 0

Is there anything obviously wrong?


Martin Zielinski wrote:

>Now, that you have a valid printer admin account - it should work. 
>Unfortunatly Samba returns ACCESS_DENIED for several reasons which have 
>nothing to do with access rights.
>Wrong accounts or passwords result in a "result was DOS code 0x00000013" 
>The only case, I could provoke this error message was, when not all files were 
>in the W32X86 directory.
Are the names really ok? My driver files are names "cupsui5.dll, 
cups5.hlp and

>Perhaps you have newer or older ones?
>The ppd file has to be in the W32X86 dir, too.
>And please check the linux permissions of the driver files.

>On Tuesday 05 October 2004 10:40, Philip Maurer wrote:
>>Tried doing that, no dice - same error message!  However, I noticed that
>>the "New Driver" button is not grayed out anymore - I get "Access
>>Denied" when trying to update the driver via that method as well.  I
>>tried chmodding drivers dir 777, still access denied...
>>             Philip
>>Martin Zielinski wrote:
>>>Hello Philip,
>>>try putting the "printer admin" parameter into the global section.
>>>It's a global parameter that cannot be used "per share".
>>>On Monday 04 October 2004 16:00, Philip Maurer wrote:
>>>>Dear list,
>>>>This problem has been bugging me for days now, I've got Cups version
>>>>1.1.21 and Samba 3.0.7 installed and working.  There is a single
>>>>Laserjet 4100 attached to the network, printing via Cups or Cups/Samba
>>>>works fine.
>>>>The problems are with getting Point'n'Print to work.  I've been scouring
>>>>the net, archived posts of this list, read the official Samba manual, to
>>>>no avail.  The problem is always the same; I can successfully copy the
>>>>drivers into the W32X86 directory using e.g. smbclient, but issuing the
>>>>adddriver command via rpcclient
>>>>rpcclient newserver -N -U'root%******' -c 'adddriver "Windows NT x86"
>>>>Always returns: result was WERR_ACCESS_DENIED
>>>>I've tried using the GUI method but when I get to the Advanced tab the
>>>>'New Driver' button is grayed out.
>>>>Best regards,
>>>>                  Philip
>>>>Here's my smb.conf:
>>>># Replace MYWORKGROUPNAME with your workgroup/domain
>>>>workgroup = NOVASOFT
>>>># Of course this has no REAL purpose other than letting
>>>># everyone know its not Windows!
>>>># %v prints the version of Samba we are using.
>>>>server string = Samba Server %v
>>>># We are going to use cups, so we are going to put it in here ;-)
>>>>load printers = yes
>>>>printing = cups
>>>>printcap name = cups
>>>>use client driver = no
>>>># We want a log file and we do not want it to get bigger than 50kb.
>>>>log file = /var/log/samba/log.%m
>>>>max log size = 50
>>>># We are going to set some options for our interfaces...
>>>>socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
>>>># This is a good idea, what we are doing is binding the
>>>># samba server to our local network.
>>>># For example, if eth0 is our local network device
>>>>interfaces = lo eth0
>>>>bind interfaces only = yes
>>>># Now we are going to specify who we allow, we are afterall
>>>># very security conscience, since this configuration does
>>>># not use passwords!
>>>>hosts allow =
>>>>hosts deny =
>>>># Other options for this are USER, DOMAIN, ADS, and SERVER
>>>># The default is user
>>>>security = user
>>>># No passwords, so we're going to use a guest account!
>>>>guest account = samba
>>>>guest ok = yes
>>>># We now will implement the on access virus scanner.
>>>># NOTE: By putting this in our [Global] section, we enable
>>>># scanning of ALL shares, you could optionally move
>>>># these to a specific share and only scan it.
>>>># For Samba 3.x
>>>>vfs object = vscan-clamav
>>>>vscan-clamav: config-file = /etc/samba/vscan-clamav.conf
>>>># Now we setup our print drivers information!
>>>>comment = Printer Drivers
>>>># this path holds the driver structure
>>>>path = /etc/samba/drivers
>>>>guest ok = yes
>>>>browseable = yes
>>>>read only = yes
>>>># Modify this to "username,root" if you don't want root to
>>>># be the only printer admin)
>>>>write list = maph,root
>>>>comment = HP LaserJet Network Printer
>>>>printable = yes
>>>>path = /var/spool/samba
>>>>public = yes
>>>>guest ok = yes
>>>>guest account = samba
>>>>printer admin = maph,root
>>>># Now we setup our printers share.  This should be
>>>># browseable, printable, public.
>>>>comment = All Printers
>>>>path = /var/spool/samba
>>>>browseable = no
>>>>public = yes
>>>>guest ok = yes
>>>>writeable = no
>>>>printable = yes
>>>>printer admin = maph,root

More information about the samba mailing list