[Samba] mount.cifs and permissions

Paul Gienger pgienger at ae-solutions.com
Fri Oct 1 18:37:39 GMT 2004

Alexander E. Patrakov wrote:

> 2) On the client, created the /smbhome directory, and executed the 
> following command:
> mount -t cifs -o user=mount,password=XXXXXX // 
> /smbhome
> This worked.
> 3) Logged in as a user. Tried to create a file in the place under 
> /smbhome where this user could do so.
> The owner of that file was expected to be that user (I wanted to have 
> just a workalike for NFS), but in reality it was root.

This is because the server uses the credentials you mounted the share 
with to be the user that is operating on the filesystem, in this case root.

> Is that a bug in SAMBA or in the kernel or just my mis-expectation? Is 
> it possible at all to use a SAMBA share as a NFS workalike?

There have been lots of people that are having problems doing things 
like mounting windows exported home dirs as unix home dirs and then unix 
apps (like kde) have lots of issues with things like symlinks and such.  
In this case why don't you want nfs aside from the 'one more service' 
thing?   There are plenty of good reasons, but they may not apply to 
your situation. 

Assuming you know your way around NFS, which it sounds like you do, you 
could have that set up in less time than it took you to type this 
message, but making two linux boxes talk across a method derived to 
support windows and nothing like unix will cause a few problems that 
could take you days to fix up, judging by the posts of people who are 
having issues with it.

Paul Gienger                     Office: 701-281-1884
Applied Engineering Inc.         
Information Systems Consultant   Fax:    701-281-1322
URL: www.ae-solutions.com        mailto: pgienger at ae-solutions.com

More information about the samba mailing list