[Samba] mount.cifs and permissions

Alexander E. Patrakov patrakov at ums.usu.ru
Fri Oct 1 18:21:55 GMT 2004

I have set up a Samba 3.0.7 server (with LDAP password database), and it 
works perfectly for Windows clients. Now we came to the need of 
supporting one Linux workstation (with SAMBA 3.0.7 client already 
installed) in addition to those Windows PCs. Kernel is 2.6.7 on both the 
client and the server.

The problem is the home directories. Usually (without SAMBA) I just 
share them via NFS in such situations and mount /home on clients. 
However, since a file server (SAMBA) was already there, I tried to avoid 
setting up NFS. The following is what I did.

1) Added another user with uid=0 on the server, generated a password.
2) On the client, created the /smbhome directory, and executed the 
following command:

mount -t cifs -o user=mount,password=XXXXXX // 

This worked.

3) Logged in as a user. Tried to create a file in the place under 
/smbhome where this user could do so.

The owner of that file was expected to be that user (I wanted to have 
just a workalike for NFS), but in reality it was root.

Is that a bug in SAMBA or in the kernel or just my mis-expectation? Is 
it possible at all to use a SAMBA share as a NFS workalike?

Alexander E. Patrakov

More information about the samba mailing list