[Samba] Trouble compiling / using mysql plugin on FreeBSD 4.8

Mitch (Bitblock) mitch at bitblock.com
Thu Nov 18 18:14:05 GMT 2004

I was following docs from
But I’m stumped

I’m running FreeBSD 4.8, and need to create a mapped relationship between
SOME windows users and SOME freebsd users

I got Samba 3.0.8 running based on :
./configure --with-krb5=/usr/heimdal
And everything works if I manually add matching Windows usernames to my
etc/passwd, so on to the next step – using the mysql.so to create the

The docs are a little sketchy, but I think I can do this right?

After reading the above doc didn’t help, I did some googling and tried:
./configure --with-krb5=/usr/heimdal --with-mysql-prefix=/usr/local/db/mysql
Which doesn’t work as I think it starts to build pieces of nss_switch or
winbind, which don’t work on FreeBSD 4.8

After more reading I saw someone reference manually running:
make bin/pdb_mysql.so
But this didn’t work either

After much experimentation and reading of Makefile I did this:
make passdb/pdb_mysql.o
make bin/mysql.so
cp /home/sysop/wce-install/samba-3.0.8/source/bin/mysql.so

So it seems the name has changed from pdb_mysql.so to mysql.so?
However I’m still getting:
[2004/11/18 00:22:07, 0] passdb/pdb_interface.c:make_pdb_methods_name(664)
  No builtin nor plugin backend for mysql found
[2004/11/18 00:22:07, 1] passdb/pdb_interface.c:make_pdb_context_list(765)
  Loading mysql:mom failed!
My config looks like this – I tried them one at a time of course
passdb backend = plugin:/usr/local/samba/lib/mysql.so:mom
passdb backend = mysql:mom

I also tried:
passdb backend = mysql:/usr/local/samba/lib/mysql.so:mom
and got: 
[2004/11/18 00:33:33, 0] lib/module.c:do_smb_load_module(57)
  Error trying to resolve symbol 'init_module' in
/usr/local/samba/lib/mysql.so: Undefined symbol "init_module"

I also tried renaming mysql.so to pdb_mysql.so

When I copied mysql.so to /usr/local/samba/lib/pdb/mysql.so I got this
[2004/11/18 00:39:25, 0] lib/module.c:do_smb_load_module(57)
  Error trying to resolve symbol 'init_module' in
/usr/local/samba/lib/pdb/mysql.so: Undefined symbol "init_module"

So I think I must be close with that
. ANY help appreciated


More information about the samba mailing list