[Samba] Winbind, still unreliable

Peter Eckhardt peter.eckhardt at dadi-linux.de
Fri Nov 12 13:56:18 GMT 2004

Hi there,

I recently posted about problems with winbind resolving names from ADS.

We have an ADS Domain Controller serving the domain MED-DUS and an NT 4 
PDC serving the domain MEDOIL.
We want to use a samba server as memberserver in the MED-DUS domain. I 
joined the samba server to the MED-DUS domain.
The domain join worked ok. All users (including MEDOIL) are visible.

Next i started winbind. Made sure (via wbinfo and getent) that 
everything is working fine and was a proud owner of a Samba fileserver.

Next we started migrating (test) user accounts. After some time 
resolving names for the MED-DUS domain stopped working. wbinfo showed 
MEDOIL domain information only. Restarting winbind fixed the situation.
I.e. MED-DUS was back again. But after some time the problem appeared again.

I tried several versions of winbind (not yet the one from 3.0.8), tried 
starting (as suggested by a helpful soul) winbind  with the -n option.

To no avail. Winbind stops serving the MED-DUS domain after some time.
I didn't see traces in the logs.

I tried samba-3.0.7 rpms from suse and sernet. Linux Distribution is 
Suse Prof. 9.0.

Anyone had the same behaviour? Anyone a clue what's going on?



dadi-linux                       www.dadi-linux.de

Peter Eckhardt                   Fon: +49 6071 951256
Weberstr. 36B                    Fax: +49 6071 951257
64846 Groß-Zimmern               peter.eckhardt at dadi-linux.de

More information about the samba mailing list