[Samba] VSS on samba

Nathan Howard nhoward at wdb-uk.com
Fri Nov 12 13:47:52 GMT 2004

We have recently moved our VSS database from windows 2k to samba, 
initially all looked fine but have come accross a problem.

Quite often VSS complains saying it can't write to "names - acess denied".

The file its refering to is names.dat in data/ (for those that know VSS)

I believe this to be some sort of locking issue. Sometimes getting all 
other clients to quite VSS solves the problem, sometimes it doesn't.

smbstatus reports things like:
5031   DENY_NONE  0x2019f     RDWR       NONE 

which afaik, shouldn't be stoping anyone from writing to it.

Although sometimes no locks appear for it at all and still VSS reports 
you can't write to it.

Viewing the file via the share I can edit it by hand (well write to it 
anyway - its some dodgy proprietry format)

The smb conf for the share is as follows:

comment = Visual Source Safe
read only = no
browsable = yes
path = /home/wdb-uk/store/vss
create mask = 0660
directory mask = 0770
oplocks = False
level2 oplocks = False

with no other locking options specified anywhere else.

I've tried with and without the oplocks statments and there is no 

There is apparerntly some way of getting VSS to use file locks where by 
it creates a lock file in data/locks/ for each locked file, but I can't 
seem to find any docs saying how to do it.

The only other notible point is that /home/wdb-uk is a mounted nfs share 
but I have tried having it locally with the same issue.

Anyone come across similar problems with VSS, google seems to report 
various locking issues but no real solutions.


More information about the samba mailing list