[Samba] Locked files stay locked - copy operation from XP to Samba fails

Bart van Dijck samba at vandijck.demon.nl
Thu May 27 12:20:33 GMT 2004


When trying to copy 5000+ files from a client PC to a Samba server I have
the following problem. Halfway during the operation it hangs on always the
same file. Windows XP (SP1) gives:
Unable to copy file [filename]. Specified network name is no longer
 (I had to translate this from Dutch, so it is not the exact message).

When checking with smbstatus I get this:

root at kylie:/etc/samba# smbstatus
Samba version 2.2.8a
Service      uid      gid      pid     machine
Werkmap Ba   bart     users     6706   bart     ( Thu May 27
13:44:01 2004
IPC$         bart     users     6706   bart     ( Thu May 27
13:46:25 2004

Locked files:
Pid    DenyMode   Access      R/W        Oplock           Name
6706   DENY_ALL   0x30196     WRONLY     NONE
/home/bart/gobnet_bart2/images/opleidingen/fotoos/fotokl/18058k.gif   Thu
May 27 13:46:33 2004

When I remove the offending files from the tree the rest of the files are
copied as you would expect. I tried removing the brlock.tdb files (when smbd
and nmbd were shut down), I then tried cleaning out the whole

I set:
oplocks = no
kernel oplocks = no
level2 oplocks = no
in smb.conf

When I check before starting the copy operation with smbstatus no files are
locked. When starting the copy the three offending files are locked and stay

Could this be related to my other problem with the Realtek 8139 and
3com2000T? Someone suggested that the giga NIC was just too fast. I checked
with 3com905B and C cards and they have the same problem, so should I revert
to the old NIC in the Samba server or are there some tweaks I could try? Any
suggestions are welcome!

Bart van Dijck

More information about the samba mailing list