[Samba] Trouble reading "config file"

Nikolaj Schulz ns at linuxhouse.dk
Thu May 20 19:10:11 GMT 2004

I have a problem every time I add new shares/restarting samba

I am running a Red Hat Enterprice with samba version: samba-3.0.2-6.3E

Samba main file only contains common aspects
I am including all the shares in a different file, using this: config 
file = /users/%U/smb.conf
This way every user can only see/access some particulare shares. This 
architecture worked perfectly under samba 2.2 but after upgrading I get 
the following problem:

- When browsing All shares are gone (except "printers & Faxes")
- When I double-click "printers & Faxes" and use the back-button all the 
correct shares are shown
- I am able to access each share by a direct link "\\Server\private" - 
and when I use the back-button all the correct shares are shown

As you see my problem is that somehow when restarting or adding new 
shares the shares will not be shown (but they are still available). As 
youprobably can understand this is not satisfactory and I have tried 
reading all kinds of documentation and HOWTOs but I cannot seem to 
identify the problem.

I would be very happy if someone could give me a hint so I can solve 
this n ightmare :)

/Nikolaj, Denmark

More information about the samba mailing list