[Samba] scandinavian letters or charset problem?

Andrew Bartlett abartlet at samba.org
Fri Mar 26 12:18:03 GMT 2004

On Fri, 2004-03-26 at 17:56, Pirkka Luukkonen wrote:
> >> Hi!
> >>
> >> This teamware mailclient (teamware.com) that we use at the office has
> >> problems adding files as attachments from our Samba 3.0.2a share. The
> >> attachment file browser sees the files but fails to add them as
> >> attachments (with an error message: "valid.stf - file not found"
> >> regardless of the file name in question). I tracked this thing down to
> >> scandinavian letters (if your mail client supports it you should see
> >> these åäöÅÄÖ) in directory names.
> >>
> >> example:
> >> g:\some-directory\some-file.png        Works OK
> >> g:\scandiåöä\some-file.png         Doesn't work.
> >>
> >> Anywhere else in Windows XP samba directories work just fine with
> >> scandinavian letters. This is the only program that behaves like this
> >> and I haven't received any help from vendor or manufacturer and they are
> >> as amazed as I am.
> >>
> >> Server is Samba 3.0.2a with winbind and the charsets are:
> >>         dos charset = CP850
> >>         unix charset = UTF-8
> >>
> >> Clients are Windows XP/2k/NT and Teamware Office 5.3/6.0.
> >
> > In the same way that Samba has had to deal with the move to unicode, so
> > have many windows applications.  In windows, the transition is to a new
> > collection of 'W' functions, for 'wide' character set.  This is a lot of
> > work, and many applications instead convert back and forth to the old
> > ASCII or OEM code page.  If your user's profile/localle is incorrect,
> > then this might be part of the issue.  The correct solution may be for
> > your application to be at least partially recoded using these
> > functions...
> >
> > How well does this work against a win2k server?  If it doesn't fail,
> > then we have something more fishy going on...
> I tested unix charsets ascii, iso8859-1 and iso8859-15 with Samba and it did
> no use. I also tried win2k and nt server shares and they worked like a
> charm. It seems clear, that the problem I have is somewhere between Teamware
> Office and Samba server. Some exception that it cannot handle, perhaps.

Can you make sure this is filed as a bug?  If we differ in behaviour
from what Win2k does, then it's a bug...

If you can get any more detail from the application vendor, then that
would be very useful too...

Andrew Bartlett

Andrew Bartlett                                 abartlet at pcug.org.au
Manager, Authentication Subsystems, Samba Team  abartlet at samba.org
Student Network Administrator, Hawker College   abartlet at hawkerc.net
http://samba.org     http://build.samba.org     http://hawkerc.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.samba.org/archive/samba/attachments/20040326/e9bb1031/attachment.bin

More information about the samba mailing list