[Samba] access 2003 clients can't print to samba 3 server ( access 2000 can)

daniel.jarboe at custserv.com daniel.jarboe at custserv.com
Wed Mar 17 17:59:45 GMT 2004

> >Has anyone else heard of or had any issues printing with Access 2003
> >samba servers?  Other office 2003 products print fine, and Access
> >worked, but Access 2003 will not print to a samba server here.  In
> >to get access 2003 to print, I have to change default printer to
> >something on a windows server, and then it works?
> >
> That sounds more than a little suspicious.
> What sort of setup do you have?
> Samba ==> CUPS?


> Raw print queue or the CUPS driver?

Raw, w2k driver installed from print$ share.  This is not a
manufacturer's driver with all the bell's and whistles either, just
simple default w2k minidriver.

> I have had some issues printing reports from Access to some of our
> printers that claim to be PCL6 compatible ( and have PCL6 drivers ),
> only work with the PCL5 drivers.
> What happens when you try to print?

Here's the latest.  When I have some samba printers installed as the
default printer, File... Print-Preview causes the window to momentarily
flash light like it redrew itself, but that's it.  File... Print
(Ctrl-P) does not seem to do anything.  No print property windows or
anything.  With Access 2000, everything worked.

With the same printers on a windows server, File... Print-Preview causes
the window (that previously just flashed light like a redraw) to display
the preview in the same window.  Print-Preview toggles back and forth
between these views.  File... Print (Ctrl-P) brings up a "Print" window,
and here I can see the samba printers that didn't work if they were the
"default printer", select them, and print using them.  But if those
printers were previously the "default printer", none of it works.

Through trial and error, I've discovered that our HP LaserJet 4050 and
8100 on the samba server both fail if they are the default, but oddly
enough a HP LaserJet IIISi on the same server works fine.

If I install one of the same failing drivers (8100) as a local printer
(even while keeping existing driver), print preview and other operations
work fine.  It's only when the samba printer is selected as the default
printer that I have problems :(.

~ Daniel


This message is the property of Time Inc. or its affiliates. It may be
legally privileged and/or confidential and is intended only for the use
of the addressee(s). No addressee should forward, print, copy, or
otherwise reproduce this message in any manner that would allow it to be
viewed by any individual not originally listed as a recipient. If the
reader of this message is not the intended recipient, you are hereby
notified that any unauthorized disclosure, dissemination, distribution,
copying or the taking of any action in reliance on the information
herein is strictly prohibited. If you have received this communication
in error, please immediately notify the sender and delete this message.
Thank you.

More information about the samba mailing list