[Samba] Weird: Samba 3.0.2a (PDC) and OpenLDAP = Windows can't logon to PDC

Joost van der Locht joost at vanderlocht.com
Sat Mar 13 18:04:23 GMT 2004


I have a weird problem. I have installed on a Fedora Core 1 server the 
Samba 3.0.2a
Openldap 2.1.22
Smbldaptools 0.8.4

Everything works for this setup until I try to logon to the domain from 
a Windows XP Pro workstation.

I can:
- join the domain
- create users with the smbldap tools
- Logon to Linux localy
- use smbclient tools
- Access shares from my Windows XP (when logged on localy)
- See my personal homedirectory and mapped to a personal share

I Can't
- Logon to the domain.

When I try to do that Windows gives the error:
The system could not log you on. Make sure your User name and domain are 
correct, then type your password again. Letters in passwords must be 
typed using the correct case.

I tried it with a non ldap setup and then it seemed to work.

Now with ldap it doesn't.
As far as I could monitor the log files I see a SUCCEED comming up when 
it checks the ldap directory. But still no luck logging in.

What is wrong? I followed every instructions I could find online 
regarding ldap.....



More information about the samba mailing list