[Samba] LDAP idmap backend

Shannon Johnson sjohnson at engr.psu.edu
Wed Jun 16 15:03:56 GMT 2004

I've been trying to get an idmap backend working in an ldap database (I
know, not really a database). I think I got most it worked out, but I'm
having a problem getting samba to bind to the ldap server. 

My smb.conf says (just the important stuff, with my domain taken out
because I'm paranoid):

idmap backend = ldap:ldap://ldapserver.subdomain.domain.com:389
ldap suffix = dc=mnelabs,dc=mne,dc=psu,dc=edu
ldap idmap suffix = ou=Idmap
ldap admin dn = cn=Manager,dc=subdomain,dc=domain,dc=com

My slapd.conf says:

suffix	"dc=subdomain,dc=domain,dc=com"
rootdn	"cn=Manager,dc=subdomain,dc=domain,dc=com"
	rootpw	long-encrypted-password starting with {SSHA}

I ran slappasswd and entered my password, and it gave me the rootpw.

I ran smbpasswd -w and used the same password as the slappasswd, and it
said it set the stored password in secrets.tdb.

Now, when I restart winbind, the log says:

[2004/06/16 10:51:52, 0] lib/smbldap.c:smbldap_connect_system(798)
  failed to bind to server with dn=
cn=Manager,dc=subdomain,dc=domain,dc=com Error: Invalid credentials

I'm not sure what the problem is, or how to fix it... I'm brand new to
ldap, but have been working with Samba for a while.

Shannon Johnson
Network Support Specialist / Systems Administrator
Dept. of Mechanical and Nuclear Engineering
224 Reber Building
University Park, PA 16802
Phone: (814) 865-8267

More information about the samba mailing list