[Samba] PRINT$ Problems

Paul Espinosa pespinosa at sunflowerbroadband.com
Tue Jun 15 13:13:37 GMT 2004

What I've found with point and print is that some drivers don't like to play
with it on Samba.  I tried installing a Brother (don't remember exact model)
on point and print and got a similar protection fault.  A while later I was
able to get a Xerox N17 working so easy I had to check twice that it was
really working.

I came to a conclusion that it had something to do with the way the
individual printer drivers interact with Samba.

Nothing I ever did got the Brother to work with point and print on Samba.

Paul Espinosa
pespinosa at sunflowerbroadband.com
IT Supervisor
The World Company

.----[ Aaron Goodman wrote ]----
|  I have been trying to setup point and print on a debian testing box.  I
|  have a HP5550 printer and am trying to install the drivers through the
|  add printer wizard, the drivers appeared to install fine.  Afterwards I
|  right clicked on the printer and clicked connect, per the SAMBA howto,
|  this also appeared to work.  When I tried to enter the properties screen
|  of the local printer or on the share I get the following error message:
|  "Function address 0x60630d26 caused a protection fault. (exception code
|  0xc0000005)
|  Some or all property page(s) may not be displayed)."
|  After the error message comes up, the properties window does not open.  I
|  cannot print either.
|  Here is the relavent section from my smb.conf:
|  -----
|  [printers]
|     comment = All Printers
|     browseable = yes
|     printable = yes
|     path = /tmp
|     writable = yes
|     create mode = 0700
|  [print$]
|     path = /etc/samba/drivers
|     browsable = no
|     guest ok = yes
|     read only = yes
|     write list = aaron root
|  ------
|  Thanks,
|  Aaron Goodman

More information about the samba mailing list