[Samba] Clients can find printer when

Steve Cohen stevecoh1 at comcast.net
Mon Jun 7 00:33:32 GMT 2004

Well, sort of.

>From one XP box (actually it's a VMWare virtual machine on the same physical 
machine as the printer is connected to) all is well.  Printing works.  The 
only problem was that I had specified a non-existent directory for my raw_q 
queue to spool to.  Changed it to the standard one and all is fine.  

Question for the group - is it good practice for different queues to spool to 
different dirs or does that matter.

>From the other XP box, this a real one, we had some success as well.  We are 
now able to attach to the raw_q queue and everything looks good.  But there 
appear to be bad connectivity issues and the print jobs fail.  

This is leading me back to consider the issues with the Domain Master Browser.
I don't know how to configure one of the Windows boxes to be the DMB.

But the main issue is solved.

On Sunday 06 June 2004 4:53 pm, McKeever Chris wrote:
> On Sun, 6 Jun 2004 15:34 , Steve Cohen <stevecoh1 at comcast.net> sent:
> >On Sunday 06 June 2004 11:16 am, fredex wrote:
> >> On Sun, Jun 06, 2004 at 10:23:46AM -0500, Steve Cohen wrote:
> >> > This is REALLY starting to annoy me.  I have now set up a Win98 client
> >> > on the network.  Once again I install the proper driver.  Once again
> >> > the Windows system can browse to the printer.  Once again, printing
> >> > appears to the client as if it's happening.  Once again nothing comes
> >> > out of the printer.  Once
> >>
> >> This is exactly the problem I've had. (Using Samba 3.0.x and Cups).
> >> someone else suggested making the particular printer in use here set up
> >> as a RAW print queue in CUPS. Requires editing two cups config files and
> >> connecting to the web UI for cups and changing the printer queue type to
> >> raw. Details can be found in the samba documentation on printing with
> >> cups.
> >
> >Hey, thanks, not sure what "printing with cups" documentation you meant,
> > but I googled and found
> > http://de.samba.org/samba/docs/man/CUPS-printing.html Was this the doc
> > you were referring to?
> >
> >This immediately seems to be getting somewhere.  I didn't have
> >printcap name = cups
> >in my conf.  And putting it there immediately changes the pattern,
> > although still not success:
> >
> >[2004/06/06 13:59:20, 0] printing/print_cups.c:cups_job_submit(655)
> >  Unable to print file to EpsonC82 -
> I had a lot of issues trying to print to this exact printer via a network
> configuration...just a thought that it may not be completely a _you_ thing
> >client-error-document-format-not-supported
> -------------------------------------------
> Chris McKeever
> If you want to reply directly to me, please use
> cgmckeever--at--prupref---dot---com <A
> href="http://www.prupref.com">www.prupref.com</A>
> Prudential Preferred Properties
> <A href="http://www.prupref.com">Chicago and Illinois NorthShore Real
> Estate Experts</A>
> ---- Prudential Preferred Properties   www.prupref.com
> Success Driven By Results
>    Results Driven By Commitment
>       Commitment Driven By Integrity
>          We Are Prudential Preferred Properties

More information about the samba mailing list