[Samba] Clients can find printer when

Steve Cohen stevecoh1 at comcast.net
Sun Jun 6 20:34:14 GMT 2004

On Sunday 06 June 2004 11:16 am, fredex wrote:

> On Sun, Jun 06, 2004 at 10:23:46AM -0500, Steve Cohen wrote:
> > This is REALLY starting to annoy me.  I have now set up a Win98 client on
> > the network.  Once again I install the proper driver.  Once again the
> > Windows system can browse to the printer.  Once again, printing appears
> > to the client as if it's happening.  Once again nothing comes out of the
> > printer.  Once
> This is exactly the problem I've had. (Using Samba 3.0.x and Cups).
> someone else suggested making the particular printer in use here set up
> as a RAW print queue in CUPS. Requires editing two cups config files and
> connecting to the web UI for cups and changing the printer queue type to
> raw. Details can be found in the samba documentation on printing with cups.

Hey, thanks, not sure what "printing with cups" documentation you meant, but I 
googled and found http://de.samba.org/samba/docs/man/CUPS-printing.html
Was this the doc you were referring to?

This immediately seems to be getting somewhere.  I didn't have 
printcap name = cups
in my conf.  And putting it there immediately changes the pattern, although 
still not success:

[2004/06/06 13:59:20, 0] printing/print_cups.c:cups_job_submit(655)
  Unable to print file to EpsonC82 - 

But that at least looks logical.

OK, now on to here:
"Raw Print Serving Vendor Drivers on Windows Channels"

which lists these steps

   1.      Edit /etc/cups/mime.types to uncomment the line near the end of the 
file that has:

   2.      Do the same for the file /etc/cups/mime.convs.

   3.      Add a raw printer using the Web interface. Point your browser at 
http://localhost:631. Enter Administration, add the printer following the 
prompts. Do not install any drivers for it. Choose Raw. Choose queue name Raw 

SLIGHT PROBLEM HERE.  The CUPS that comes with RedHat 9.0 tells you to handle 
this through "redhat-config-printer" However, it proves easy to set up this 
way and shows up with the Cups 631 interface.

Another Slight Problem.  The name "Raw Queue" is not acceptable, I think 
because of spaces.  And anyway, I think this conflicts with the name in step 
6 below ("raw_q").  I choose to name it raw_q and we look good.

   4.      In the smb.conf file [printers] section add use client driver = 
Yes, and in the [global] section add printing = CUPS, plus printcap = CUPS.

Now here's a step they left out:  restart the cups and smbd daemons.  I'm on 
top of that.

   5.      Install the printer as if it is a local printer. i.e.: Printing to 

I can do it that way, I can also do it in XP by creating a new port first.  
Doesn't matter.  We fail in the next step.

   6.      Edit the configuration under the Detail tab, create a local port 
that points to the raw printer queue that you have configured above. Example: 
\\server\raw_q. Here, the name raw_q is the name you gave the print queue in 
the CUPS environment. 

AARGH!  Still no good.  What Windows configuration are they talking about?  
Where is the detail tab.  Well, anyway, I find a place where I can add a new 
local port.  I enter \\Rainier\raw_q and get "File Not Found"

Ever closer, but still no cigar.

More information about the samba mailing list