[Samba] Lock ups?

Chris samba at hal.kaos.gen.nz
Wed Jun 2 08:52:54 GMT 2004

I'm still having this problem despite tweaking various things on my XP
client and a few things on the Debian Samba server. It must be a Samba
problem becasue I get the same effect on two different XP clients and one
Linux client.

The network layer is fine (all cards swaped round and/or replaced. Switch
replaced and there are no ethernet errors. Locked at 100 meg full duplex
throughout on all cards. (I must say it's the fastest network I've created
after all this farking about).

I have put up an ethereal capture taken during one of the pauses if anyone
cares to have a look. I'm seeing what looks (to my untrained samba
eye) like funny behavior. The trace
was started after the "freeze" started. It lasted about 10 second during
which the Samba server was unresponsive. The Debian samba server is and the XP client is



I'm seeing normal traffic till the lock.. then some trans2 response
<unknown>. packets...

then at packet 18 the pause ended and I see some error "status cancel"
messages (god only knows) and some SMB close requests.. then everything
comes right and the data starts streaming as normal.

Anyone got any suggestions?

On Mon, 31 May 2004, Chris wrote:

> Hi there. I'm reasonably new to Samba but quite experainced with Linux.
> The other day I decided to throw a file server together for my house. I
> put together a Linux box with 5 120 gig drives raid 5'd in a rack mount
> box and put it in the basement.
> It's running debian and Samba 3.0.2a-1. The Kernel is 2.4.26.
> I am then mounting the drive as a mapped network drive under a windows XP
> box that is my main PC.
> Initially all seemed good. I filled the raid and started using the PC. I
> am however getting what appear to be "lock ups" regularly when browsing
> the samba share I have created. I'll be browsing happy as larry with music
> also streaming off the share when my explorer window will lock up and the
> music will stop playing. Any attempt to open "My Computer" or any explorer
> window to access the share results in nothing. If I wait 10 seconds to 1
> min it suddenly comes right and everything pootles along again as normal.
> If I just stream 1 file off the server then it's fine for (the longest
> I've tried) up to 2 hours. But if I start browsing the shares or opening
> other shared files I get lock ups within 1-5 min. It's very frustrating
> when I'm trying to do multiple things at once.
> I ran ethereal on the windows end and when the pauses happen I see SMB
> messages flying round but they seem to be requests for the same bit over
> and over.. Usually as the pause ends I see a close request going from the
> XP box to the Linux server. I can provide ethereal captures if that would
> help.
> I am also SSHed into the server and it's not a drive pause as the drive
> and mounted dir are totally responsive under linux while the pause is in
> effect.
> I don't think it's network related as I have 100 meg full duplex locked
> all the way through. Both PC's are plugged into a Cisco 2950 and I see no
> itteruption of traffic between the two when a pause occurs.
> Below is my SMB conf.... any suggestions? My GF is going to kill me if her
> photo editing keeps locking up like this. :)
> ------
> [global]
> server string = %h server (Samba %v)
> netbios name = atari
> wins support = yes
> dns proxy = no
> log file = /var/log/samba/log.%m
> max log size = 1000
> syslog = 0
> panic action = /usr/share/samba/panic-action %d
> encrypt passwords = true
> passdb backend = tdbsam guest
> obey pam restrictions = yes
> passwd program = /usr/bin/passwd %u
> [shared]
>    comment = Storage
>    writable = yes
>    locking = yes
>    oplocks = True
>    create mask = 0700
>    directory mask = 0700
>    path = /raid-1/shared
>    public = yes
> ------
> --
> To unsubscribe from this list go to the following URL and read the
> instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list