[Samba] LDAP connection leak?

Gémes Géza geza at kzsdabas.sulinet.hu
Sat Jan 24 09:37:38 GMT 2004

Hash: SHA1

Wil Cooley írta:
| On Fri, 2004-01-23 at 14:50, Andrew Bartlett wrote:
|>I would not think that 52 was high, given the number of files that slapd
|>has to open before it starts serving connections anyway.
|>Samba will open one connection per smbd, and nss_ldap will open one per
|>program using nsswitch.   Standard posix semantics ensures these close
|>on daemon shutdown.
|>Do you have anything that indicates that we are actually leaking (rather
|>than just using) connections?
| Yeah, I think you're right and there is no leak.  I checked and there
| are 30+ smbd with the same number of open connections to slapd; plus the
| connection from nscd (shouldn't nss_ldap open only one connection when
| using nscd?).  I'll keep a closer eye on it to see if the number grows;
| I'm still left trying to figure out why slapd started logging "deferring
| operation" and what happened to the system, but those are questions for
| another list.
| Wil

I don't have an answer for your problem, but I've had something similar:
OS:		Mandrake 9.1
kernel:		2.4.19
openldap:	2.0.27
~From the local machine everything worked well nss_ldap, pam_ldap, samba,
phpLdapAdmin, lam, gq, etc. Connecting over TLS, SSL or without
encryption. However connecting from remote clients, even anonymously,
with, or without encrypted connections, sometimes freezed (the processes
were running, but the connecting clients had to wait forever for an
answer, so with nss_ldap, and pam_ldap it made the system hanging)
openldap. Unfortunately I wasn't able to find out the origin of the
problem. But it seems that upgrading to openldap-2.1.22 solved it.


Version: GnuPG v1.2.3 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org


More information about the samba mailing list