[Samba] HELP with "no mapping between account names and security ids was done" - SOLVED

Michael Gasch gasch at eva.mpg.de
Wed Jan 21 14:13:14 GMT 2004


am i not stupid :D ?!?!!?

the account of the machine in ldap had the wrong (old) DOMAIN-SID
that's why it didn't work...

i set the SID of the machine in LDAP to `net getlocalsid $mydomain` and 
it worked ;)

possibly it helps some other people...


Michael Gasch wrote:
> hi
> i've been sucessfully using samba 3.0.0 and win2k/xp clients in a domain
> if i try to add a win2k/xp workstation in a samba 3.0.1 controlled 
> domain (with the same smb.conf as the 3.0.0 PDC), i always get
> "no mapping between account names and security ids was done"
> the same workstation can enter a 3.0.0 controlled domain with no problems !
> machine accounts were also created
> so there can't be a problem with the machine account (which is found in 
> ldap while trying to join the domain) or users/groups, because the 3.0.0 
> PDC has the same users/groups (and mappings) as the 3.0.1 PDC
> i'm out of knowledge....
> plz help
> thx


          "Matrix - more than a vision"

Michael Gasch
Max Planck Institute for Evolutionary Anthropology
Deutscher Platz 6
04103 Leipzig


More information about the samba mailing list