[Samba] Broken Pipe error

robert.thorpe at antenova.com robert.thorpe at antenova.com
Tue Jan 6 11:31:52 GMT 2004

My company did lot of "far-reaching" IT systems changes.
They seem to have broken an installation of Samba on a HP-UX machine.

I can:

ssh to the machine.
Use X remotely.
Ping it by name.
Ping from it by name.

But Samba doesn't work.  When I try to access it I get the error "The
semaphore timeout period has expired".

When I look in the Samba logs I get a list of messages that look like:

[2004/01/06 10:44:56, 0] lib/util_sock.c: (565)
  write_socket: Error writing 4 bytes to socket 7: ERRNO = Broken pipe
[2004/01/06 10:44:56, 0] lib/util_sock.c: (754)
  Error writing 4 bytes to client. -1. Exiting

I've tried starting and restarting Samba.

The OS is HP-UX, the version of Samba is 2.0.7.
There are a few posts on the internet that connect it with DNS problems. 
But few are specific as to what DNS problems.  I've tried accessing it from
machines that use DHCP and ones with static IP addresses.  I've tried
accessing it only by IP address, which also doesn't work.

Thanks for your help.

More information about the samba mailing list