[Samba] Connect to W2K share from Linux

Walls Rob W Contr 75 CS/SCBS Rob.Walls at HILL.af.mil
Fri Jan 2 22:08:31 GMT 2004

Having trouble connecting to a share on a windows machine from a linux
I have been using samba for years to map from linux to windows, but no luck
the other way around.
I've read lots of how-to's but none of them work and don't even mention the
problem I'm having. I always get access denied errors. Tried the samba
troubleshooting guide which does talk about access errors, but nothing I do
makes the windows machine accept a connection from samba. (I have no problem
connecting from the win machine to the linux machine, though.) I am admin on
both machines.

Linux machine is running redhat 9 and samba 3.0.1pre3 (using user security)
also tried it on redhat 7.2 with samba 2.0.10 
Windows machine is running W2K Server SP4 
both machines are currently on the same subnet.

Set up share named smbtest on W2K. 
set up mount point /mnt/smbtest in Linux.
set up hosts entry on Linux to point winnetbiosname to IP address to
eliminate any DNS or WINS problems
set up samba credentials file containing:
set up fstab with 
//winnetbiosname/smbtest /mnt/smbtest smbfs
W2K permissions - share:everyone, NTFS: tried AD user, AD group, local Win
user and even local Win everyone group

also tried using the smbmount command, but get same result: "unknown
username or bad password" in W2K event log and "28511: session setup failed:
ERRDOS - ERRnoaccess (Access denied.)" from samba on Linux box.
I AM prompted for a password using smbmount, BTW.

The W2K machine is a member server in Active Directory. I've tried using
domain-name\user.name. I've also setup a local user on the W2K box and tried
to connect using that as well, same, same, same...grr...

Do the win and linux accounts have anything to do with each other?
Can you use dots and dashes in usernames? My domain requires first.last
usernames and passwords must contain special chars.
How do you delimit passwords that contain special chars? I've tried using
double quotes, but again, same error.
Can you make samba use AD for auth instead of a NT4 domain controller? Our
domain does not have any NT4 domain controllers. I'll use a local win user
on the win machine if necessary, but would rather not.

Any idea?

More information about the samba mailing list