[Samba] samba printing - help!

Jordan Thompson Jordan at ThompCo.com
Sat Feb 14 17:49:20 GMT 2004

Hi there,

My Mandrake server has been working fine for years, and I just
recently tried adding some rpms to get my squirrel mail updated. (Of
course I just removed my uneeded sound card at the same time, amd also
found my /var was filling(fixed - printing still doesn't work_, so I am
not sure what (if any) broke my system. Any how... here are the

(1) I can access my shared samba directories from my windowze clients.
(2) I can access (see) my shared samba printers (they appear
as "ready" in the printers folder from my windoze machines.)
(3) I can print from linux (test page as well as documents)

(4a) (And here is the problem) when I try to print from my windoze
machines, either nothing happens (no warning, error, etc), I get a "A
StartDocPrinter call was not issued"), or "Windows cannot print due
to a problem with the current printer setup. Try one of the
following:..." depending on the application.

(4b) When I check the windows queue for the printer, there is nothing

(4c) When I try to print a test page (printer->properties->Print Test
Page), I get: "Test page failed to print. Would you like to view the
print trouble shooter for assistance? Unable to create a print job."

I am getting the same problem from both my windoze 2000 and xp
machines on two different printers, and the error comes back
instantly (no waiting for the server to make up its mind.)

Here is an exerpt from my smb.conf (hack and slash are the two
printers - what can I say, my kids and I are fans of the television
show Reboot):

log file = /var/log/samba/log.%m
guest account = guest
load printers = yes
passwd chat debug = Yes
ldap ssl = yes
status = yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
null passwords = yes
map to guest = never
domain master = no
encrypt passwords = yes
hosts allow =
dead time = 0
password level = 0
wins support = no
dns proxy = No
netbios name = DOT
server string = Dot %v
printing = cups
unix password sync = no
workgroup = REBOOT
os level = 0
debug level = 0
security = user
preferred master = no
max log size = 50
use client driver = yes


lpq command = cups -o %p
printer = hack
printable = yes
print command = lpr-cups -P %p -o raw %s -r
public = yes
path = /var/spool/samba
lprm command = cancel %p-%j
comment = hack Lexmark e210
guest ok = yes
print ok = yes

printer = slash
lpq command = cups -o %p
printer name = slash
create mask = 0700
hide dot files = no
share modes = No
public = yes
lprm command = cancel %p-%j
root preexec close = no
oplocks = No
printable = yes
preexec close = no
print command = lpr-cups -P %p -o raw %s -r
inherit permissions = no
writable = yes
path = /var/spool/samba
comment = slash HP Deskjet 882C
use client driver = yes
guest ok = yes
print ok = yes

I tailed the /var/log/samba/log.phong (note phong is a windoze
client) and got:
[2004/02/10 12:10:20, 0] tdb/tdbutil.c:tdb_log(531)
tdb(/var/cache/samba/printing.tdb): rec_free_read bad magic 0x0 at
[2004/02/10 12:10:20, 0] tdb/tdbutil.c:tdb_log(531)
tdb(/var/cache/samba/printing.tdb): rec_read bad magic 0x0 at

Any help will be most appreciated.


Jordan R. Thompson
Mail:Jordan at ThompCo.com
Tel:(321) 777-8377
Cel:(321) 501-2259
Fax:(509) 267-5577

More information about the samba mailing list