[Samba] Browsing and Test 8 (diagnosis.txt): net view \\xscale fails with no assigned share names (Smb-2.0.9 Snapgear Win2k)

Edmond Dantes edmond99 at gmx.net
Thu Feb 12 14:57:47 GMT 2004

Dear Samba Gurus,

having a browsing problem with W2k (German Version) on my 2.0.9 server
(also tried 2.0.7 before), you are my last hope to help me soling my
Everything is working fine accessing the samba server from linux, no
problem at all, all shares are listet with exact namewith smbclient -L
ixdp425 (Intel Xscale Developper Plattform ixp425 Proz.)
I'm also able to "net use" the shares from the W2k clients, or to direct
access the shares by name e.g. with win commander by "cd \\ixdp425\temp"

the test "net view \\ixdp425" is the first test that fails, not meaning
to terminate with error, but to produce the following unexpected output:

Name         Typ          Lokal    Beschreibung (Description)

                   Platte (Disk)
Der Befehl wurde erfolgreich ausgeführt.
(Command terminated successfully!)

The corresponding Linux test with smbclient -Lixdp425 will show the
following correct share names

Domain=[HOME] OS=[Unix] Server=[Samba 2.0.9]

       Sharename      Type      Comment
       ---------      ----      -------
       temp           Disk      temporary space
       IPC$           IPC       IPC Service (Samba 2.0.9)

       Server               Comment
       ---------            -------
       IXDP425              Samba 2.0.9
       Workgroup            Master
       ---------            -------
       HOME                 IXDP425

My server is an Intel Arm Xscale based on Snapgears uC-Linux with Glibc
I'm running the Intel Access Library Version 1.3 and Kernel Version 2.4.20

My smb.conf is as following simple
   encrypt passwords=yes
   netbios name=ixdp425
   preferred master = yes
   local master = yes
   domain master = yes
   browseable = yes
   comment = temporary space
   browse list = yes

Searching in Windows 2000 will also produce any results, only when samba
isn't running the developpers board is found.
Browsing the Entire Network the explorer will also produce an Error in
german: (Auf Ixdp425 kann nicht zugegriffen werden, der Netzwerkname
wurde nicht gefunden.) which means
in my translation Ixdp425 cannot be accessed, the network name was not
found. It's showing up to shares in the tree, but they don't have any
names assigned to.
I tried almost every complex and simple configuration, with/without
lokal and/or domain masters for more then 4days now without success.

So I hope someone else has some better ideas to solve my problem than me
Thanks in advance and best regards,


More information about the samba mailing list