[Samba] Photoshop can't save files, gives bogus "Disk is full" error

JW jw at uninetsolutions.com
Thu Feb 5 22:57:05 GMT 2004


I am having dreadful problems with Win2k workstations running Photoshop not 
being unable to save files to a new file server which we just installed for
the direct purpose of serving graphics files.

When trying to Save As a new file or Save an edited (existing) file we're
getting a response that the disk is full, which is far from true because we
have 1.6 TB free. This happens both with a mapped drive and through Network
Neighborhood. Photoshop is the _only_ application that causes this behavior.
I have had similar issues  a couple years ago with intermittant problem on a
small SAMBA server but I never found a solution for it.

I currently have access to a few other LANs where both Photoshop on Win2k
and a nearly identical SAMBA setup (SuSE 9.0, samba-2.2.8a-107 are
installed, these locations do not seem to have the same problem.
There is also another (older) samba server on the same lan as the one we are
having trouble with, and the exact same clients do not seem to have this
problem with the other SAMBA server. I have duplicated the smb.conf off the
"working" server, changing only the netbios name and the map-to-guest user,
and still have the problem. I do not know why the one works. It is not much
older, and the pervious server I had trouble with a few years ago was, if
anything, even older than the "working" server (whereas the new
"non-working" server has a newer samba version). 
I do not have direct access to the LAN where the current problem is, so I
can't send any logs or give too many details right now, sorry.

I will say that I have worked over the phone with another tech who was
on-site for several hours yesterday, and we have tried nearly every
possible configuration with turning on/off locking, changing all the create
modes/masks, changing users, security level, and everything else we could
think of that could possibly effect this situation.

A quick search shows that a few dozen people have had either exactly the
same problem or a very similar one:


This is a very bad problem for us, and I'm feeling quite discoraged to see
that there are reports of this from 1, 2 even 3 years ago, and no reported

Did anyone ever find a solution for the problem? 
If not, what must I do to help find it -- it is very, very important that we
get this solved once and for all.

I will try to get a copy of the log file.



More information about the samba mailing list