Chris chrisd at better-investing.org
Tue Aug 24 13:52:36 GMT 2004


I noticed a few unanswered posts here and on bugzilla regarding smbmount.  
And, of course, it is not working right for me either.  Bugs like:



What used to happen with smbmount was that I would mount a share like so:

smbmount //somesever/someshare /mnt/samba -o username=myname,worgroup=wgroup

And this would mount the directory so that the server would think that all 
files transferred were owned by "myname", and all umasks, dirmasks etc. would 

This is no longer true.  It resembles more of an NFS mount:  if my UID or GID 
does not own a file or dir, I cannot access it -- period.  Even if I am 
listed as an admin user in the smb.conf.  When files are moved to that share, 
none of the create masks or directory masks get applied.

This is a major problem for me, because I need administrative access to *ALL* 
home shares on the server.  Furthermore, many utility scripts run on the 
server crash because the permissions are not set right!  I used to do this 
with samba 2.0.7a and it worked beautifully.  I have used 3 different 
versions of samba 3.x, and it no longer works.

I have tried everything listed in the man page for options (like dmask, fmask, 
krb), and it has not made a difference.

Long and short of it:

1) smbmount does not mount (or at least retain the mount) as the user 

2) The create masks, directory masks etc. are not applied to smbmounted shares 
resulting in files with bad permissions.

I am using 3.0.4 in an ADS environment.  My server is a domain member of a 
2003 domain.

Is this broken, or is there something that can be done?  Help!



More information about the samba mailing list