[Samba] Unable to browse workgroup, shares otherwise accessible

Stalkerbrother stalkerbrother at djmobsters.com
Mon Apr 26 19:38:05 GMT 2004


Thanks for the responses.

I did a testparm, which is OK, workgroup is identical, and I do not have to
add the "3" to the command names in my case. I have researched this problem
some more and I think it might have something to do with my guest account
settings. Under Mandrake 9.2 I never setup a guest account explicitly, it
just worked without it. I do not have a "nobody" account, which is the
default samba guest account, so I setup a "smbguest" account and I set
"guest account = smbguest" with no samba password required. This did not
help but I increased the log level to 3 and got among others the following
log output:


[2004/04/26 21:00:53, 3] smbd/password.c:register_vuid(240)
  UNIX uid 503 is UNIX user smbguest, and will be vuid 101


[2004/04/26 21:00:53, 2] lib/access.c:check_access(324)
  Allowed connection from  (
[2004/04/26 21:00:53, 3] smbd/service.c:make_connection_snum(543)
  Connect path is '/var/tmp' for service [IPC$]
[2004/04/26 21:00:53, 3] lib/util_seaccess.c:se_access_check(251)
[2004/04/26 21:00:53, 3] lib/util_seaccess.c:se_access_check(252)
  se_access_check: user sid is S-1-5-21-824483728-3943587780-1468999615-501
  se_access_check: also S-1-5-21-824483728-3943587780-1468999615-514
  se_access_check: also S-1-1-0
  se_access_check: also S-1-5-2
  se_access_check: also S-1-5-32-546
  se_access_check: also S-1-5-21-824483728-3943587780-1468999615-2009
[2004/04/26 21:00:53, 3] smbd/vfs.c:vfs_init_default(203)
  Initialising default vfs hooks
[2004/04/26 21:00:53, 2] smbd/uid.c:change_to_user(141)
  change_to_user: Invalid vuid used 101 or vuid not permitted access to
[2004/04/26 21:00:53, 0] smbd/service.c:make_connection_snum(627)
  Can't become connected user!
[2004/04/26 21:00:53, 3] smbd/error.c:error_packet(118)
  error packet at smbd/reply.c(286) cmd=117 (SMBtconX)
[2004/04/26 21:00:53, 3] smbd/process.c:process_smb(890)
  Transaction 9 of length 43
[2004/04/26 21:00:53, 3] smbd/process.c:switch_message(685)
  switch message SMBulogoffX (pid 18085)
[2004/04/26 21:00:53, 3] smbd/sec_ctx.c:set_sec_ctx(288)
  setting sec ctx (0, 0) - sec_ctx_stack_ndx = 0
[2004/04/26 21:00:53, 3] smbd/reply.c:reply_ulogoffX(1108)
  ulogoffX vuid=101
See the attached file for a more complete log output. I think the key to my
problem is in the log entry:

[2004/04/26 21:00:53, 2] smbd/uid.c:change_to_user(141)
  change_to_user: Invalid vuid used 101 or vuid not permitted access to

I also found that browse problems can be caused by several things, but they
should often be related to guest access problems to IPC$. Do not know if
this is the case here but it seems so even though my guest account should be
setup now. I have not yet been able to find any relevant information on
this, but I hope someone can help. Until then I will continue digging and
there are others that can benefit from an answer to this problem...


-----Original Message-----
From: Matthew J. DiBattista [mailto:MJDme at ITtechs.com] 
Sent: 26. april 2004 17:35
To: 'Stalkerbrother'
Subject: RE: [Samba] Unable to browse workgroup, shares otherwise accessible

Are the workgroup name the same?

I upgraded Samba 2.28 to 3.02 on mdk 9.2 and I have to add a 3 at the end of
testparm3, samba3 status, samba3 start 

Did u do testparm


Matthew J. DiBattista
Information Technology Technicians

-----Original Message-----
From: Stalkerbrother [mailto:stalkerbrother at djmobsters.com] 
Sent: Saturday, April 24, 2004 4:38 PM
To: samba at lists.samba.org
Subject: [Samba] Unable to browse workgroup, shares otherwise accessible



After upgrading from Mandrake Linux 9.2 to Mandrake Linux 10 I can no longer
browse my workgroup domain in "My Network Places" from my XP Pro clients.
However, I can still access the shares on my Samba server without problem
using either "Add Network Place" or by entering the path directly in
Explorer. Another symptom is found in my Samba log where a lot of the
following messages are being produced:


[2004/04/24 22:18:13, 0] smbd/service.c:make_connection_snum(627)

  Can't become connected user!


Everything worked perfectly prior to the upgrade, and currently everything
besides the workgroup browsing issue still works. I am not a Samba expert,
and I searched the net without any decisive results, so I would really
appreciate if someone could help me out here. Below you will find essential
smb.conf data. Samba version is 3.0.2a.







            log file = /var/log/samba/log.%m

            smb passwd file = /etc/samba/smbpasswd

            interfaces = eth1 lo

            bind interfaces only = yes

            load printers = yes

            socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

            map to guest = bad user

            encrypt passwords = yes

            user = stalkerbrother

            printer admin = @adm

            dns proxy = no

            netbios name = Blofeld

            server string = Blofeld

            printing = cups

            default = global

            workgroup = WORKGROUP

            hosts allow =

            os level = 20

            local master = yes

            invalid users = root bin daemon adm sync shutdown \

                        halt mail news uucp operator

            valid users = @users

            printcap name = cups

            security = user

            lanman auth = no

            lm announce = no

            max log size = 50

            dns proxy = No

            idmap uid = 10000-20000

            idmap gid = 10000-20000

            template homedir = /home/%D/%U

            template shell = /bin/bash

            comment = Home Directories

            browseable = no

            writable = yes



   comment = Home Directories

   browseable = no

   writable = yes



            comment = Directory for all users to share files

            path = /home/shared

            public = yes

            writable = yes

            valid users = @users

            write list = @users

More information about the samba mailing list