[Samba] nt_status_no_trust_sam_account

Hamish captainmish at gmx.net
Fri Apr 23 09:55:51 GMT 2004

I am a bit lost with a problem here, I have samba 3.0.2a on a suse 9 
i386 box, samba installed from suse rpm.
It is (was) joined to a 2003 AD domain. I had a pdf printer that was 
working yesterday and not working this morning.

Changes made between yesterday and this morning:
added "Netbios name = filetest2"
removed netbios name
AD admin password changed (I dont think this will affect samba?)

When I run wbinfo -t it returns:
checking the trust secret via RPC calls failed
error code was NT_STATUS_NO_TRUST_SAM_ACCOUNT (0xc000018b)
Could not check secret

I tried to rejoin the domain:
net join -S domserver -U Administrator
This returned:
realm must be set in in smb.conf for ADS join to succeed. (the 2k3 box 
does not use kerberos)
ADS join did not work, falling back to RPC...
Joined domain MYDOMAIN.

I have security =domain

As i said, it was working yesterday (i cant believe i said that, sorry 
and support people!) so there must be something small, or a change on 
the 2k3 server... any ideas?

Thanks again

More information about the samba mailing list