[Samba] No local SID -- net getlocalsid fails

Andrew Bartlett abartlet at samba.org
Thu Apr 22 08:46:01 GMT 2004

On Thu, 2004-04-22 at 00:11, John Arthur wrote:
> > Excellent!!! Glad it worked out... Just curious... Did you run "net rpc
> > info" prior to adding a user? If so, did it return the proper SID?
> > 
> Hi Marcus,
> Since I could repoduce the problem I tried a new setup. As you can see
> 'net rpc info' returned no information. However as soon as I'd run
> 'net rpc info' 'net getlocalsid' worked.

I *think* I have fixed this for 3.0.3 - we now always try to get or make
up a sid, before we report it.  This also ensures we get any SID that
may be present in LDAP, for example.

Andrew Bartlett

Andrew Bartlett                                 abartlet at pcug.org.au
Manager, Authentication Subsystems, Samba Team  abartlet at samba.org
Student Network Administrator, Hawker College   abartlet at hawkerc.net
http://samba.org     http://build.samba.org     http://hawkerc.net
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: This is a digitally signed message part
Url : http://lists.samba.org/archive/samba/attachments/20040422/697d0275/attachment.bin

More information about the samba mailing list