Tue Apr 13 07:36:03 GMT 2004

Hi Mariusz,

I found this thread at SAMBA.ORG:


 I can't remember for certain, but try using a relative path.
> (e.g. vscan-mksd.so).
I tried relative and non-relative path, with this same effect 
but you've right because in manual for samba-vscan we can read 
that in samba 3.0 we should use relative path.
I had increase debug level of samba daemon and in my log I 
have found
[2003/12/12 06:38:00, 3] smbd/vfs.c:vfs_init_custom(227)
   Initialising custom vfs hooks from [vscan-mksd.so]
[2003/12/12 06:38:00, 5] lib/module.c:smb_probe_module(102)
   Probing module 'vscan-mksd.so'
[2003/12/12 06:38:00, 5] lib/module.c:smb_probe_module(113)
   Probing module 'vscan-mksd.so': Trying to load from 
after that, I had type:
cd /usr/local/samba/lib/vfs
ln -s vscan-mksd.so vscan-mksd.so.so
and now I see in log from my workstation:
[2003/12/12 07:41:34, 3] smbd/vfs.c:vfs_init_default(201)
   Initialising default vfs hooks
[2003/12/12 07:41:34, 3] smbd/vfs.c:vfs_init_custom(227)
   Initialising custom vfs hooks from [vscan-mksd.so]
[2003/12/12 07:41:34, 5] lib/module.c:smb_probe_module(102)
   Probing module 'vscan-mksd.so'
[2003/12/12 07:41:34, 5] lib/module.c:smb_probe_module(113)
   Probing module 'vscan-mksd.so': Trying to load from 
[2003/12/12 07:41:34, 5] smbd/vfs.c:smb_register_vfs(191)
   Successfully added vfs backend 'vscan-mksd'
[2003/12/12 07:41:34, 5] mks/vscan-mksd.c:init_module(510)
   samba-vscan (vscan-mksd 0.3.4) registered (Samba 3.0), (c) 
by Rainer Link, Ope
[2003/12/12 07:41:34, 2] lib/module.c:do_smb_load_module(64)
   Module '/usr/local/samba/lib/vfs/vscan-mksd.so.so' loaded
[2003/12/12 07:41:34, 0] smbd/vfs.c:vfs_init_custom(254)
   Can't find a vfs module [vscan-mksd.so]
[2003/12/12 07:41:34, 0] smbd/vfs.c:smbd_vfs_init(317)
   smbd_vfs_init: vfs_init_custom failed for vscan-mksd.so
but it's still not-working, and I don't know why, tomorrow I 
will try do symlink to the other places where samba can search 
this modules, now my company is working and I can do any test.
If anyone have any sugestion I will gracefull



Could you solve this problem meanwhile?
I'm fighting with same problem.
With the help of your thread, i'm able to load the vscan-clamav module, but it seems to me, that the scanner doesn't work. If i copy the EICAR test to the share, there is no warning or anything else.
What did you do?

Thank's for help!

With best regards

Rainer Breuer

Mockel + Breuer oHG
Heuweg 20
06886 Lutherstadt Wittenberg
T.: +49 (0) 34 91 / 64 64 64
F.: +49 (0) 34 91 / 64 64 - 999

More information about the samba mailing list