[Samba] No My Network Places or Net Neighborbood Icons, & /tmp log entries

Curt Harms charms at ameritech.net
Mon Apr 5 21:12:51 GMT 2004


	I am having the following problems with Samba:
		1) My server system is not immediately visible to windows machines, 
i.e., there is no icon in "My Network Places" XP, or in "Network 
Neighborhood" in 98. I am able to manually log into the system via 
Windows XP by doing the run command for my server name. I am also able 
to log in via Mac OS X, but I must also specify a directory 
smb://bucket/charms for example. I am unable to log in via Window 98 at 
		2) I get lots of entries in my log similar to the following:
			Apr  5 15:47:29 bucket smbd[3253]: [2004/04/05 15:47:29, 0] 
			Apr  5 15:47:29 bucket smbd[3253]:   '/tmp' does not exist or is not 
a directory, when connecting to [IPC$]
		The /tmp directory is permissions are 777, yet I continue to get this 
	I am running Samba 3.0.2a on a Gentoo Linux machine with the 2.6.4 
kernel. SMB support is compiled into the kernel. I previously tried 
2.2.8a and had similar problems.
	I have done my best to be sure that the workgroup, WINS server, etc. 
settings are correct on all the machines.
	My config file reads as follows (with a few item ***ed out for 
     workgroup = *******
     writeable = yes
     encrypt passwords = yes
     wins support = yes
     browsable = yes
     server string = Samba %v on %h
     hosts allow =
     hosts deny =
     syslog only = yes
     log level = 1
     oplocks = no
     level2 oplocks = no
     invalid users = ****, ****
     username level = 3
         security = user
         passwd program = /usr/bin/passwd
         unix password sync = yes
         domain master = yes
     local master = yes
     preferred master = yes
     os level = 255
     domain logons = no

         browsable = no
         writeable = yes

         path = /bucket/archive
         comment = The Main Archive
         browsable = yes
         volume = archv
         writeable = yes
         strict locking = yes
         valid users = @employees
         create mode = 0660
         directory mode = 0770
         admin users = ***, ***

	I would REALLY appreciate any help that I can get on this issue. I 
have tried everything I can think of and cannot fix the problems.
							Thanks so much,
								Curt Harms

More information about the samba mailing list