[Samba] roaming profiles

Andre de Koning andre at vippayroll.co.za
Wed Sep 10 09:32:58 GMT 2003

I managed to delete the temporary cached profile on one of the windows boxes
but when I now log onto that machine with the user in question if get:

Windows cannot log you on because the profile cannot be loaded.  Contact
your network administrator
DETAIL - Access denied

I haven't tried w2k sp4 yet - downloading now but what bugs me is that it
did work before and only gave me problems from time to time - now it
constantly does it!

any ideas?


-----Original Message-----
From: kurt weiss [mailto:input.maillists at kwnet.at]
Sent: 10 September 2003 09:50
To: Andre de Koning
Cc: samba at lists.samba.org
Subject: Re: [Samba] roaming profiles

hi andre
see below for my comments.

Andre de Koning schrieb:

> Hi all.
> I'm runnig samba as a DC with win2k clients using roaming profiles.
> Since installation I have been experiencing problems with users unable to
> log in due to their profiles not loading - some users are on w2k prof end
> some use w2k terminal services.

> It maily complains about not being able to load (or copy) files like
> "prf23.tmp" - access denied etc.
> Most of the time if I delete the file in question in eg.
> "profiledir/Nethood", "profiledir/Application
> en when I log on again it works.
> It now started the profile cannot be loaded bacause some file cannot be
> copied and when I go delete the file in the profile dir in the samba box
> try again as usual it still tells me that the profile "cannot be loaded -
> logging you in with a temporary profile" - when I click OK a box just pops
> up saying "profile cannot be loaded - access denied".
> This seems to be entirely random - different client machines and terminal
> servers and different user accounts every time.  Sometimes I have to
> the w2k terminal server for the problem to go away and sometimes I have to
> restart smb on the linux box.  This always only fixes some of the users'
> logins but others can't log in again - it also only lasts for about 3
> that were back when we started.
> Sometimes I have to completely delete a user's profile and log into w2k
> it to be recreated before it works again.
> I also noticed than if I try to delete the temporary copy of the user's
> profile in "Documents and Settings" just after I got the problem I get
> "Access Denied" or "Cannot delete, directory not empty" messages from
> windows.  When this happens, changing the permissions or ever changing the

this is the problem...
your client-side copy is damaged. u *must* get ownership for the broken
files as administrator, then u can correct the rights.
this u have to do with *every* broken file. (sh.. i know...)

we had the same problems. for me it seems, that it's a w2k problem.
especially therefore, that ms has corrected such failures in sp4.

as far as we used samba 2.2.2 we used the switch
in smb.conf for the profile share to prevent us from this issue.

in samba 2.2.8a all is running fine without this switch.
but we've allready installed sp4 on *all* our w2k clients.

> files' ownership to Administrator does not help - I have to restart the
> machine completely.

restarting the client helps?

> I was originally runnig samba 2.2.1a and tried upgrading to 2.2.3, 2.2.5
> this morning to 2.2.8a.  I also upgraded from redhat 6 to 7 to 7.1 and
> week to 8.0 but this does not make any difference.  I've tried service
> 2 and 3 on the w2k boxes but to 4 - some of my software does not work when
> is loaded.

i've only checked this two configurations:

samba 2.2.2 with 'NT ACL SUPPORT = no' on the profile share
w2k sp2 and sp3

samba 2.2.8a *without* 'NT ACL SUPPORT = no' on the profile share
w2k sp4
('NT ACL SUPPORT = no' was not running in this case, but i can't remind
the symptoms.)

i hope it helped. - let me know

> Any ideas?
> André de Koning
> IT Manager
> Softline VIP Payroll
> Tel: +27 12 420 7000
> andre at vippayroll.co.za

More information about the samba mailing list