[Samba] Multi-IP question

Greg ssac at shaw.ca
Tue Oct 14 23:12:40 GMT 2003

Hi all-

I'm fairly new to samba, but have been using 2.2.8 on a local subnet,
192.168.0.x, without problem.  The PC with samba is running NetBSD, and
has 4 ethernet i/fs, all on different subnets, on different hubs, and
has Windows 2k clients.  I now need to switch samba to two of the other
i/fs instead (the 192.168.1.x and 192.168.2.x subnets), and when I do, I
can see the NetBSD box from Windows but can't see any of the shares
(path not found error from Windows).

I have tried adding the following in my smb.conf:

remote announce =

which didn't seem to work.

I also tried adding

interfaces = tlp1 tlp2

which also didn't seem to work (the i/fs are detected in order during
boot as sip0 - the 192.168.0.x subnet, tlp0, tlp1 and tlp2).

I can ping, telnet, ftp, use ssh, etc over the interfaces, so the
connection is good, and all the Windows clients are set up identically.

I can also use smbclient at the samba machine to login to the server via
localhost to see the shares.  If I use nmblookup -B server __SAMBA__, it
shows only the first subnet (? shouldn't it show both subnets?), but it
looks correct (as far as I know...) and nmblookup -B client '*' gives
positive name query responses from the Windows boxes.

But still no shares visible from Windows.

If I switch the conf back to 192.168.0.x, it works fine (and
smbclient/nmblookup tests give the same type of results as for the other

I imagine (hope!) I'm missing something obvious; I have googled and read
as many of the configs/man pages that I could find, so I apologize if
this is in some FAQ somewhere...

Thanks for any help

More information about the samba mailing list