[Samba] Samba 3 - pending print jobs not being shown

daniel.jarboe at custserv.com daniel.jarboe at custserv.com
Tue Oct 7 17:34:33 GMT 2003

Samba 3 linked against cups.  I have a problem that is best illustrated
when a printer is paused in cups.  When looking at the "Printers" folder
for a samba server, often documents is "0" even though there may be some
pending.  Manually refreshing will sometimes cause them to reappear or
dissapear.  Furthermore, listing jobs for the individual queue is broken
too.  Occassionally the jobs may reappear, but usually, whether
refreshing or not, the jobs aren't shown.  I've tried various lpq cache
time's without luck.  This is with printing = cups and printcap name =

For grins I've also tried without the cups libraries linked (with no
better luck).  The server is on a different subnet than the clients...
should that make a difference?  I also tried setting printing = sysv and
manually specifing the lpq command, and get similarly inconsistent
(usually worse, though) results.

Is anybody else seeing anything similar?
~ Daniel


This message is the property of Time Inc. or its affiliates. It may be
legally privileged and/or confidential and is intended only for the use
of the addressee(s). No addressee should forward, print, copy, or
otherwise reproduce this message in any manner that would allow it to be
viewed by any individual not originally listed as a recipient. If the
reader of this message is not the intended recipient, you are hereby
notified that any unauthorized disclosure, dissemination, distribution,
copying or the taking of any action in reliance on the information
herein is strictly prohibited. If you have received this communication
in error, please immediately notify the sender and delete this message.
Thank you.

More information about the samba mailing list