[Samba] RedHat 9 Samba and SWAT

Ow Mun Heng ow.mun.heng at wdc.com
Fri Oct 31 01:20:32 GMT 2003

Can you do a nmap localhostr/ip of your PC and see if port 901 is open??

Cheers,                                                 .^.
Mun Heng, Ow                                            /V\
H/M Engineering                                       /(   )\
Western Digital M'sia                                  ^^-^^
DID : 03-7870 5168                          The Linux Advocate


-----Original Message-----
From: Todd O'Bryan [mailto:toddobryan at mac.com]
Sent: Thursday, October 30, 2003 7:24 PM
To: samba at lists.samba.org
Subject: [Samba] RedHat 9 Samba and SWAT

Hi all,

I've googled and discovered that others have had this problem, but no 
one has given sufficient details about how they solved it, so I'm still 

As preface, I'm a high school teacher, and although I teach 
programming, my sysadmin experience is minimal, so please be explicit 
in your replies.

I've been following the instructions in the O'Reilly Samba book for 
configuring, compiling, and installing Samba, but seem to hit a snag 
when it comes time to get SWAT working.

Is it just me, or has swat moved from /usr/local/samba/bin/swat to 
/usr/local/samba/sbin/swat in the 3.0 default install? I've tried 
changing that in the xinetd.d/swat file, and I think it leads to the 
second error below.

Anyway, I do what it says, and I get "Connection refused" errors when I 
try to connect to "http://localhost:901". After playing with things for 
a while, I managed to get it to say "Document contains no data". I look 
in the Services panel, and it says swat needs xinetd to run. Meanwhile, 
xinetd says it's running and has a PID.

I've seen this question several times, but there is no recipe for 
resolving it anywhere that I can find. A link to a How-To would be 
great. Failing that, if someone who knows what they're doing has time 
to step through the RedHat 9.0/Samba 3.0 install, it's clear that the 
published How-To (both in the O'Reilly book and in the Samba 
documentation) don't quite work, either because paths have changed or 
steps were left out. Fixing these would make my life easier and avert a 
not so inFAQ.


P.S. If I'm doing something really stupid, please let me know.

To unsubscribe from this list go to the following URL and read the
instructions:  http://lists.samba.org/mailman/listinfo/samba

More information about the samba mailing list