[Samba] solution to domain reboot problem

Aaron K. Johnson akjmicro at comcast.net
Thu Oct 23 22:21:47 GMT 2003


I had a problem with rebooting XP and joining the samba domain, which was 
controlled by my gentoo linux box. I worked for days
for a solution, and found it....!!!!

The problem was that I could join the domain fine, but had to reboot, and then 
found i was rejected from joining then. It appeared like the domain was 
invisible to the XP box.

I pulled my hair out, scoured the web unsuccessfully, then stumbled upon this 
solution, using the log files from samba. I found that it was rejecting the 
user 'smbguest' as not existing. None of the HOWTO's mention this importatn 
fact, a testament to how shitty linux people are at documenting EXACTLY what 
needs to be done, in general.

do the following:

as root, add this line to /etc/passwd:


make sure '1202' is not taken by anything
else...change it to something close if it

also, make sure your 'workstation' group is
defined as described in


then do:

	smbpasswd -a smbguest

give it a password you like, etc.

BTW, make sure you've done that for 'root' too:

	smbpasswd -a root

(skip that if you have)

kill and restart samba and your windows
box. log onto the domain using 'smbguest'
and your password. It worked for me. I
screamed with joy inside (I had been unable
to log onto the domain from XP for days...)

Hope this helps anyone out there....


P.S. I also took down the XP firewall, as
I'm using a linksys router. Make sure too
that the WINS server in the TCP/IP setting
on XP is defined to be that of your Samba
server, and you've done that registry hack
for entering domains. 

OCEAN, n.  A body of water occupying about two-thirds of a world made
for man -- who has no gills. -Ambrose Bierce 'The Devils Dictionary'

More information about the samba mailing list