[Samba] shared files not locked -> samba culprit or clients?

Dmitry Melekhov dm at belkam.com
Sun Oct 19 07:41:29 GMT 2003

----- Original Message -----
From: "Jeremy Allison" <jra at samba.org>
To: "Dmitry Melekhov" <dm at belkam.com>
Cc: <samba at lists.samba.org>
Sent: Saturday, October 18, 2003 11:57 AM
Subject: Re: [Samba] shared files not locked -> samba culprit or clients?

> On Sat, Oct 18, 2003 at 12:47:55PM +0400, Dmitry Melekhov wrote:
> >
> > Unfortunately this patch doesn't solve all locking problems :-(
> > As i wrote (I posted mail to samba-technical by mistake) I have locking
> > problems with current CVS.
> I don't know of any outstanding problems. I tried to reproduce
> the problem you reported on Samba-technical and was unable to
> do so (the two user opens of an Excel spreadsheet worked fine
> for me). You didn't contact me with follow up information on
> what your problem was.

Just because I don't have such information :-(
I can't reproduce my problems too.
Is it possible to reproduce Excel crash? ;-)
But I asked how can I see what happens, i.e. where samba 3 store locks info?
No replies :-(
Again, even deleting of locking.tdb didn't help.

And another problem, when smbstatus reported file, locked by unexistent
process is not reproducable too.
Just because I can't do it on production server  and can't simulate workload

> Please don't allege general locking problems on the list without
> trying to follow up with someone investigation your problem first.

Sorry, but there are _general_ locking problems in samba 3.
And, sorry, I have no technical info which can help to solve problem.
(yet? ).

May be somebody here had the same problems:

After MS Excel crash file becomed "busy", i.e. Excel said that file is
opened by another user and can be opened only read-only.

smbstatus didn't show that there is lock on this file.
Only way to open file was to disable locking in smb.conf.

I even deleted locking.tdb and no results, file still can be opened only as
fuser and lsof didn't show any locks on kernel level.

smbstatus showed that file is locked, but there was no such smb process

More information about the samba mailing list